Closed Bug 1523243 Opened 7 months ago Closed 7 months ago

[Outdated plug-in] Sherlock plug-in for LEO is outdated (German version of Firefox)

Categories

(Firefox :: Search, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- fix-optional
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- fixed
firefox67 --- fixed

People

(Reporter: ripper, Assigned: flod)

Details

(Whiteboard: [qa-66b-p2])

Attachments

(2 files)

Attached file opensearch_ende_de.xml

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36 OPR/52.0.2871.64

Steps to reproduce:

1.) In the german version of Firefox, switch the default search engine to "LEO Eng-Deu"
2.) Search for any word or phrase

Actual results:

Search opens http://dict.leo.org/ende?lang=de&from=fxdesktop&search=gehen

which redirects (301) to

https://dict.leo.org/englisch-deutsch/gehen

Expected results:

The search should open the correct URL (https vs. http and changed address). I've attached the original opensearch file from LEO (see https://dict.leo.org/pages/helpers/shared/searches/opensearch_ende_de.xml ) but removed the "v2.0" part from the ShortName. Maybe consider adapting that file to include the "from" parameter?

Status: UNCONFIRMED → NEW
Component: Untriaged → Search
Ever confirmed: true
Version: 63 Branch → Trunk
Assignee: nobody → francesco.lodolo

I've removed the Romansh version, since the only difference was in the description, and it's unused in the UI.
Updated suggestions URL format for use <Param> instead of a single URL.

Wow, very fast. Looks good to me!

Pushed by francesco.lodolo@mozillaitalia.org:
https://hg.mozilla.org/integration/autoland/rev/6582c6fb87ef
Update URLs in LEO searchplugin, remove Romansh variant r=mkaply
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Verified with 67.0a1 (2019-02-04) (64-bit)

Status: RESOLVED → VERIFIED

Comment on attachment 9039486 [details]
Bug 1523243 - Update URLs in LEO searchplugin, remove Romansh variant

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

While the website has a redirect that makes the existing searchplugin work, they might remove it and break the shipping searchplugin. We also spare one redirect.

Is this code covered by automated tests?

Unknown

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Only affecting two locales (de, rm), and fix verified in Nightly.

String changes made/needed

None

Attachment #9039486 - Flags: approval-mozilla-beta?

Comment on attachment 9039486 [details]
Bug 1523243 - Update URLs in LEO searchplugin, remove Romansh variant

Fixed URL for a German search engine. OK to uplift for beta 5.

Attachment #9039486 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: [qa-66b-p2]
You need to log in before you can comment on or make changes to this bug.