Add Array#flat and flatMap to @@unscopables

RESOLVED FIXED in Firefox 67

Status

()

enhancement
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: till, Assigned: anba)

Tracking

(Blocks 1 bug)

Trunk
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

5 months ago

The proposal for adding flat and flatMap to Array.prototype has been amended to add the names to Array's list of unscopable names.

We're shipping flat and flatMap since 62, and they just advanced to stage 4, so we should add them to unscopables soon.

Assignee

Comment 1

4 months ago
Assignee: nobody → andrebargull
Status: NEW → ASSIGNED
Attachment #9044670 - Flags: review?(jorendorff)
Attachment #9044670 - Flags: review?(jorendorff) → review+
Assignee

Updated

4 months ago
Duplicate of this bug: 1530865
Assignee

Updated

4 months ago
Keywords: checkin-needed

Comment 4

4 months ago

Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fa45218ad1c5
Add "flat" and "flatMap" to Array.prototype[@@unscopables]. r=jorendorff

Keywords: checkin-needed

Comment 5

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.