Profile import does not allow to specify destination directory

VERIFIED DUPLICATE of bug 60734

Status

VERIFIED DUPLICATE of bug 60734
16 years ago
10 years ago

People

(Reporter: herter, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The profile manager is magnificent so far, assuming that you have enough 
space on the system disk C:. This is not the case on my machine at home. 
I can not let the entire huge email/news article collection to be copied
to the drive C:. In contrast to the creation of the new profile, the 
import function does not support user specified profile location and always 
will copy all data to its default place on C:\WINDOWS.

I would suggest to allow user to specify path for the imported profiles 
or to add a profile relocation function. The current situation prevents
me from migrating to Mozilla 1.0 at home...
(Reporter)

Comment 1

16 years ago
Is this problem at a dead end? I receive countless progress notes about other
problems, such as mouse handling, but here is a complete silence. 

May I ask if there is a chance for at least a review and an opinion about this
problem?

Thanks in advance. 

Comment 2

16 years ago
Using Mozilla 1.1 Gecko/20020826 browser on Windows 98, when the browser is
opened for the first time, one can choose the directory for the profile variable
files.  However, in creating additional profiles this option is not allowed. 
Variable files for these profiles are put in a default directory
C:\Windows\Application Data\Mozilla etc. in my case.

Because of this problem I am only using the browser at present because there is
not enough room on my C: drive for all my mail files.  Also, having all variable
files and data files on a drive separate from the program files simplifies
backing up.

Comment 3

16 years ago
For comment #1, In reading your description it sounds like you want to migrate a
profile into a specified location.  We don't support that at this time and there
is a know bug already logged (60734).  I will mark this as a dup of that one. 
If I'm wrong about your request reopen the bug and comment on the specifics. 
Just an fyi...we don't import profiles, we create new ones or migrate existing
ones from 4.7.  
What we do import are: Eudora, Outlook or Outlook express mail accounts or mail
settings into and existing profile.  Address books from the same app as well as
the 4.7 address book and 4.7 address book import formats. 

For comment #2, With our current release and daily builds users can select an
alternate location for their newly created profiles.   When launching the
Profile Manager, select Create Profile, then click Next.  In this second panel
the user can change the default location for their new Profile by clicking on
the Choose Folder button.   If this is not your request, please log a new bug
with specific steps.  

*** This bug has been marked as a duplicate of 60734 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified dup
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

16 years ago
I am sure that the comment #2 refers to the very same problem as the 
comment #1, it just uses a better wording: The import utility 
copies the news and mail files to the drive C:, which might be too small.

In my case C: holds the OS only and is quite small. This improves the 
performance significantly as it preserves the system files in their 
non-fragmented condition. Thus all I am asking for is the ability 
to specify the location of the new created user profile based on the
old Netscape 4.8 profile.
"Thus all I am asking for is the ability 
to specify the location of the new created user profile based on the
old Netscape 4.8 profile."

That's bug #60734.

Sorry, we don't have a way to do that yet.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.