If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

WinAmp .WSZ skin file behaviour on download

VERIFIED DUPLICATE of bug 91969

Status

SeaMonkey
Download & File Handling
--
minor
VERIFIED DUPLICATE of bug 91969
16 years ago
13 years ago

People

(Reporter: Jason Barnabe (np), Assigned: Blake Ross)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

.WSZ Winamp Skin files are executable files that automatically change the skin
on Nullsoft Winamp when run (MIME type interface/x-winamp-skin). Mozilla doesn't
offer the option to run the file from it's current location or to save to
temporary folder and then run. Instead, it must be saved to the hard drive, run,
then deleted.

Reproducible: Always
Steps to Reproduce:
1. Attempt to download WSZ file from
winamp.com/skins/detail.jhtml;$sessionid$J4LWIJV25Q541TN24UYBCYY?componentId=101899
or any other skin from that site. Must have Winamp installed first.

Actual Results:  Offered to open using an application or to save file to disk.

Expected Results:  Should be offered to run file from current location without
saving to hard drive (save to temporary location and execute). After doing this,
the file should download and execute, which would change the Winamp skin.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 91969 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.