Closed Bug 1524158 Opened 2 years ago Closed 2 years ago

markdown generated by approval comment form could be improved

Categories

(bugzilla.mozilla.org :: Extensions, defect)

Staging
defect
Not set
minor

Tracking

()

RESOLVED FIXED

People

(Reporter: glob, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

46 bytes, text/x-github-pull-request
Details | Review

the comments generated by the approval comment generator are a bit hard on the eyes

-=-=-=-=-

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

personalized recommendations would appear in private browsing

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

No

Needs manual test from QE?

No

If yes, steps to reproduce

covered by test, but manual str if desired would be to check for the header via network monitor on a private window.

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

minimal change

String changes made/needed

none

-=-=-=-=-

playing around it looks a bit more readable with the next step down of headers

-=-=-=-=-

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

personalized recommendations would appear in private browsing

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

No

Needs manual test from QE?

No

If yes, steps to reproduce

covered by test, but manual str if desired would be to check for the header via network monitor on a private window.

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

minimal change

String changes made/needed

none

-=-=-=-=-

Agreed. Making the change now.

Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Component: General → Extensions: BMO
Component: Extensions: BMO → Extensions: FlagTypeComment
Attached file GitHub Pull Request (obsolete) —

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

It could be further improved by using a table.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached file GitHub Pull Request v2
Attachment #9040313 - Attachment is obsolete: true

Actually I didn’t use a table, because it cannot contain line breaks. On GitHub <br> works but on Bugzilla HTML tags will be escaped…

Status: REOPENED → ASSIGNED

v2 merged to master.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED

I just was Bug 1522923 Comment 5 and this is much better!

Assignee: kohei.yoshino → nobody
Component: Extensions: FlagTypeComment → Extensions
You need to log in before you can comment on or make changes to this bug.