phabricator revisions list on bug page has extra / in the revision link

RESOLVED FIXED

Status

()

RESOLVED FIXED
2 months ago
a month ago

People

(Reporter: aryx, Assigned: dkl)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Clicking on "Subscribe"/"Unsubscribe" on Phabricator/Differential pages redirects to https://D<differential id>/

E.g. click on "Subscribe"/"Unsubscribe" at https://phabricator.services.mozilla.com//D18082

A reload of the page shows the subscription status has changed.

Fallout from the upgrade in bug 1523612?

Flags: needinfo?(dkl)
(Assignee)

Comment 1

2 months ago

Ok so if you include the extra slash in the revision URL, the subscribe/unsubscribe button fails. If the extra slash is missing then it works as expected.

Fails:
https://phabricator.services.mozilla.com//D18082

Works:
https://phabricator.services.mozilla.com/D18082

I can file this with the upstream and see if they can suggest a fix.

Where did you get the failing URL? From an email from Phabricator? Somewhere external?

Flags: needinfo?(dkl) → needinfo?(aryx.bugmail)

Go to bug 1524213 and click the ID on the left of the phabricator revisions list.

Flags: needinfo?(aryx.bugmail)
(Assignee)

Comment 3

2 months ago

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #2)

Go to bug 1524213 and click the ID on the left of the phabricator revisions list.

Ah I see that. That is a BMO extension we wrote so that is our fault. I will get that fixed. Thanks.

Assignee: nobody → dkl
Status: NEW → ASSIGNED
Component: Phabricator → Extensions: PhabBugz
Product: Conduit → bugzilla.mozilla.org
Summary: Subscribe/Unsubscribe buttons redirected to url just with phabricator revision/id as host → phabricator revisions list on bug page has extra / in the revision link
Version: unspecified → Production
(Assignee)

Comment 4

2 months ago
Posted file GitHub Pull Request
(Assignee)

Comment 5

2 months ago

Merged to master.

Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
(Assignee)

Updated

a month ago
Duplicate of this bug: 1525963
You need to log in before you can comment on or make changes to this bug.