Closed Bug 1524525 Opened 11 months ago Closed 10 months ago

Password input field keydown event regression

Categories

(Core :: DOM: Events, defect, P2)

65 Branch
Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1523635
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- fixed
firefox66 --- fixed
firefox67 --- fixed

People

(Reporter: tknudsen, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached file Minimal reproduction

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

  1. Attach keydown event listener to an input with type password
  2. Load the page in Firefox
  3. Open developer tools console
  4. Input a character in the input field

This behavior changed from FF64 to FF65.
I also tested FF66 and FF67 nightly, it's the same behavior as FF65.
All tests done on Ubuntu 18.04 fully updated

This behavior change was as I can see not noted in the FF65 release notes, and must therefore be a regression?
Maybe caused by https://bugzilla.mozilla.org/show_bug.cgi?id=354358 or https://bugzilla.mozilla.org/show_bug.cgi?id=968056 which is the only changes related to keydown as far as the release notes say. But neither of those mention changes to the way password events are dispached

See attachment for minimal reproduction.

This also might be the cause of https://bugzilla.mozilla.org/show_bug.cgi?id=1523635 ?

Actual results:

FF65/FF66/FF67 behavior:
One event is fired with the keycode 229 (Process).

Expected results:

FF64 behavior:
Two events are fired, one with keycode 229 and one with the actual key pressed

Component: Untriaged → DOM: Events
Keywords: regression
Product: Firefox → Core
OS: Unspecified → Linux

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a38ee229fe1b7ab29d3bce205b8c8611e4a8297e&tochange=f17b7ba6d0aa737d4f69a0fc3206da8c539225e5

Regressed by: f17b7ba6d0aa Masayuki Nakano — Bug 1505147 - nsWindow::OnKeyPressEvent() shouldn't dispatch eKeyDown event when IMContextWrapper::OnKeyEvent() has already dispatched it for the event r=m_kato

@:masayuki,
Your patch seems to cause the regression. Can you please look into this?

Blocks: 1505147
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(masayuki)

Perhaps, dup of bug 1523635. I'll investigate it and maybe mark this as dup of it.

Flags: needinfo?(masayuki)
See Also: → 1523635

(In reply to Masayuki Nakano [:masayuki] (JST, +0900) from comment #2)

Perhaps, dup of bug 1523635. I'll investigate it and maybe mark this as dup of it.

Thank you Masayuki for the prompt investigation!

Priority: -- → P2
Duplicate of this bug: 1524907

Okay, this is completely same bug as bug 1523635.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1523635
You need to log in before you can comment on or make changes to this bug.