Serious privacy bug on Fennec - does not delete history on exit

RESOLVED DUPLICATE of bug 1269159

Status

()

defect
RESOLVED DUPLICATE of bug 1269159
3 months ago
2 months ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox 64
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 months ago

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

"clear data on exit" is enabled, all the relevant boxes therein are marked except "Downloads" and "Saved Logins". In "Advanced", "Restore tabs" is set to "Don't restore tabs after quitting Fennec". "Do Not Track" and "Tracking Protection" always enabled.

I performed a search on Google.com in anonymous mode (not logged into Google, I do not even have an account there), then I "quit" the app (i.e. close).

Actual results:

Google.com remembers my search term and shows it in the search suggestion history (also shows the option "forget history"). This is clearly because Fennec did not clear the data. Only if I delete the local data of Fennec the search history is deleted, but of course this also removes bookmarks, saved logins, plugins etc.

Expected results:

Local data should be deleted on quitting the app, and Google should not remember my history.

(Reporter)

Comment 1

3 months ago

I apologize if this is not the right place to report this bug, I am new to Bugzilla.

(Reporter)

Comment 2

3 months ago

Update: apparently performing manually Fennec->Settings->Clear private data does the trick. This does not solve the issue, as it should be done automatically on quitting the app.

Might be a duplicate of bug 1269159?

(Reporter)

Comment 4

2 months ago

(In reply to Jan Henning [:JanH] from comment #3)

Might be a duplicate of bug 1269159?

Very likely, yes!

Updated

2 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269159
You need to log in before you can comment on or make changes to this bug.