Last Comment Bug 152481 - HTTP Authentication doesn't work when typed in request line
: HTTP Authentication doesn't work when typed in request line
Status: VERIFIED DUPLICATE of bug 23679
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal (vote)
: ---
Assigned To: Darin Fisher
: Tom Everingham
: Patrick McManus [:mcmanus]
Mentors:
http://username:password@www.anyserve...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-17 19:16 PDT by Safari Shane
Modified: 2002-07-17 16:01 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Safari Shane 2002-06-17 19:16:33 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

Typing http://user:pass@somewhere.com should get you logged into IIS servers
requiring basic authentication.  And it does with other browsers.  
Also, when going to a page that requires authentication, no dialog ever comes up
to let you type it in.  Your immeditaly presented with the 401, instead of the
agent resending the request after gather the appropriate authentication information.

Reproducible: Always
Steps to Reproduce:
1.Find a server that needs authentication (not necessarily SSL)
2.Notice you can login just fine with IE
3.Find out that you can't with mozilla

Actual Results:  http 401

Expected Results:  200
Comment 1 benc 2002-06-24 17:07:25 PDT
-> http
Comment 2 Darin Fisher 2002-06-24 18:17:23 PDT
benc, tever: can you reproduce this in-house?  thx!!
Comment 3 Tom Everingham 2002-06-28 17:09:44 PDT
works for me with apache server

working on setting up an IIS server with basic auth
Comment 4 Safari Shane 2002-06-30 18:51:46 PDT
hmmm...  you may need to try it with a domain reference in the http request as 
well.  The servers I tried with all require domain login, and work fine in IE 
but not mozilla.  (of course, this means iis)
Comment 5 Tom Everingham 2002-07-08 14:56:52 PDT
ok I will look into that, using an internal IIS server I get the message:

"HTTP Error 401

401.2 Unauthorized: Logon Failed due to server configuration

This error indicates that the credentials passed to the server do not match the
credentials required to log on to the server. This is usually caused by not
sending the proper WWW-Authenticate header field."

works fine with IE.  Will attach a packet trace shortly.





Comment 6 Gagan 2002-07-08 15:34:05 PDT
Tever: can you add the login/passwd info here to the internal server so that we
could debug this? thx.
Comment 7 Tom Everingham 2002-07-11 14:04:06 PDT
http://appman.nscp.aoltw.net/test

user : qaguest
pass : qaguest

Comment 8 Tom Everingham 2002-07-11 15:04:56 PDT
ok, it appears as though the server was not configured for basic authentication. 
According to the server owner, there are 3 choices in the IIS setup for 
authentication methods - 1) allow anonymous  2) basic  3) win nt challenger.  
Basic auth has since been applied and now this works for me.  NS 4.79 also did 
not work until basic was applied.

I tested using the http://username:password@www.anyserver.com format on winNT4, 
linux rh6, and mac osX and they are all working.   Server: Microsoft-IIS/4.0

Safari, do you know if the server you are using is set up for basic auth?
Comment 9 Safari Shane 2002-07-14 13:40:57 PDT
The server is setup for integrated windows authentication.  I guess I should be 
reporting this bug to microsoft ie instead of you guys then, huh?  Looks like 
your right, there wrong.
Comment 10 Matthias Versen [:Matti] 2002-07-14 17:52:59 PDT
Mozilla doesn't support NTLM at the moment.

dupe of bug 23679


*** This bug has been marked as a duplicate of 23679 ***
Comment 11 Tom Everingham 2002-07-17 16:01:34 PDT
verified duplicate

Note You need to log in before you can comment on or make changes to this bug.