Closed Bug 1525118 Opened 2 years ago Closed 2 years ago

[meta] Run taskcluster task from mach try on Bitbar

Categories

(Core :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: egao, Assigned: egao)

References

Details

(Keywords: meta)

Bitbar has their win10/aarch64 device set up in their data centre.

Attempt a ./mach try push to try-server and have the task spin up on the win10/aarch64 hardware hosted at Bitbar.

Blocks: 1522997
No longer depends on: 1520867, 1522997, 1523722, 1524114, 1524400, 1524410

Treeherder: https://treeherder.mozilla.org/#/jobs?repo=try&revision=cce9d762caf0947068c01e6472422305975f5ada

Taskcluster: https://tools.taskcluster.net/groups/OMyfvByoTEqqJEo-tjCaSw

win10/aarch64 hardware hosted at Bitbar running generic-worker 12.0.0 accepts build task and is able to successfully build and sign.

xpcshelltest is invoked and the tests are started, however according to the logs every test experiences a timeout. Eventually runxpcshelltests.py is no longer able to schedule new threads:

22:03:15     INFO -  Traceback (most recent call last):
22:03:15     INFO -    File "C:\tasks\task_1549067048\build\tests\xpcshell\runxpcshelltests.py", line 1667, in <module>
22:03:15     INFO -      main()
22:03:15     INFO -    File "C:\tasks\task_1549067048\build\tests\xpcshell\runxpcshelltests.py", line 1662, in main
22:03:15     INFO -      if not xpcsh.runTests(options):
22:03:15     INFO -    File "C:\tasks\task_1549067048\build\tests\xpcshell\runxpcshelltests.py", line 1429, in runTests
22:03:15     INFO -      mobileArgs, **kwargs)
22:03:15     INFO -    File "C:\tasks\task_1549067048\build\tests\xpcshell\runxpcshelltests.py", line 1535, in runTestList
22:03:15     INFO -  TEST-START | xpcshell-child-process.ini:dom/indexedDB/test/unit/test_key_requirements.js
22:03:15     INFO -      test.start()
22:03:15     INFO -    File "c:\mozilla-build\python\Lib\threading.py", line 745, in start
22:03:15     INFO -      _start_new_thread(self.__bootstrap, ())
22:03:15     INFO -  thread.error: can't start new thread

Issue may be due to chunk count not being set to 8 (default 1) for windows platform.

Summary: Run taskcluster task from mach try on Bitbar → [meta] Run taskcluster task from mach try on Bitbar

Previous run was building a win64/x86_64 image and using that on the win10/aarch64 hardware in an attempt to run xpcshell.

This obviously led to errors.

A newer run: efMBjsn0Q66A2tvOdHEHDw has been scheduled.

xpcshell has been confirmed to run successfully on the win10/aarch64 hardware, pushed through Taskcluster to the generic-worker. See test-windows10-aarch64/opt-xpcshell-1

Changes that were required to support this run as done by jmaher: https://hg.mozilla.org/try/rev/fb161d0cd20f46a2558cef0d75cb2185c903f3ed

Treeherder: link

Taskcluster: link

The following changes were made by jmaher to add windows10-aarch64/opt and enable tests: https://hg.mozilla.org/try/rev/fb161d0cd20f46a2558cef0d75cb2185c903f3ed

Tests have been running on win10/aarch64 hardware for several hours, with good results.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.