Closed Bug 1525174 Opened 3 years ago Closed 2 years ago

[about:addons] Support plugin activation settings in HTML view

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox67 --- wontfix
firefox68 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

References

Details

(Whiteboard: [feature-scope])

Attachments

(2 files)

When an add-on is a plugin it should not have a remove option and should instead have an option to change it's activation settings. These are: "Ask to activate", "Always activate", "Never activate". These only seem to apply to Flash and Always and Never sort of map to enabled/disabled. Maybe Flash can just have a checkbox for Ask to active or something. Confirm with UX.

Whiteboard: [feature-scope]
Blocks: 1533795
No longer blocks: 1505924
Priority: P2 → P1
Summary: Support plugin activation settings in HTML view → [about:addons] Support plugin activation settings in HTML view
Assignee: nobody → mstriemer
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/571327e1a5e4
Plugin active states for HTML about:addons r=kmag,flod
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Regressions: 1547495

:egao, I noticed that we had a few perma fails on win/arm64 and this new test is failing- it is a plugin related test and we need to skip it like all the other plugin tests since plugins are intentionally disabled on this platform.

you can see bc4 is where it is added:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=win%2Caarch64%2Cbrowser-chrome&fromchange=ff3ec9547e4f15209af87010ed39a0590c253efe&tochange=fd9f15fe0ec120717b9690ace0b1a42bb01f48a9&selectedJob=243018628

:egao- could you disable this test for win/aarch64 when you get a chance?

Flags: needinfo?(egao)

:jmaher - I've attached a patch to disable this test on windows10-aarch64 on bug #1547495.

Flags: needinfo?(egao)
Attached image Bug1525174.gif

This issue is verified as fixed on Firefox 68.0a1 (20190505213908) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached video.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.