Closed Bug 1525224 Opened 10 months ago Closed 6 months ago

Window is not fully wide maximized (margin on left and right), not showing WIndows taskbar sometimes, unable to resize unmaximized window

Categories

(Core :: Window Management, defect, P3)

66 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: czautohits, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [tor][fingerprinting][fp-triaged])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

Steps to reproduce:

Using Firefox

Actual results:

Hello,

i have longer term issue with FIrefox (currently 66.0b4) and Tor browser (currently based on Firefox 60.5.0esr), i bet issue started sometime with Quantum arrival.

  • Maximised window has side margins (not maximised to the edges of the screen - left, right). And more importantly:

  • very soon happen that i am not able to restore minimized firefox window (it do not restore, only shows tabs in the Windows 10 64b context menu when i right click the taskbar item) and i have to close Firefox.

On start it is maximised correctly for like 3 seconds but then go wrong.

  • Firefox window that is not maximised usually can not be resized (do not change mouse cursor to resizing).

When i open new window, then it is maximised properly. But when i unmaximise new window and maximise, it gets wrong.
When i do F11 to show full screen, and restore back, i can resize and move unmaximised window. (I was unable to even move it today for a while).

  • Another issue i spot is that sometimes maximizing Window hides MS WIndows taskbar (where are app icons, tray and start button)

  • when i unmaximize window, it shrinks its height significantly. But width is kept as i set it.

My Windows is NOT fully up to date.

Hi, thanks for reporting this bug.

For specifically Tor-related issues, I would recommend filing a bug on the Tor bug tracker.
https://trac.torproject.org/projects/tor

I think the taskbar disappearing on full screen is intended behavior.

I am unable to reproduce these behaviors on the following specs:

Version 66.0b8
Build ID 20190214195736
User Agent Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Moving to Core: Layout component. Please correct to the right component if this is not the case. Thank you.

Component: Untriaged → Layout
Flags: needinfo?(czautohits)
Product: Firefox → Core

Arthur, is it useful to keep this bug open, or should this really be filed downstream on the Tor bug tracker?

Flags: needinfo?(arthur)

The torbrowser-specific window-sizing quirks (extra side margins, etc) sound related to Letterboxing, the feature discussed in bug 1407366.

Let's move this to that bug's component and mark it as a dependency, to get a step closer to having the right folks involved here.

Blocks: letterboxing
Component: Layout → Window Management

Thanks Daniel! This actually isn't letterboxing, (but good guess!) because letterboxing isn't in Tor Browser yet. But it's definitely some sort of bug.

Going to pass to Richard to see if there is somethign on file over in tor's bugtracker for this.

Blocks: fingerprinting-breakage
No longer blocks: letterboxing
Flags: needinfo?(richard)

We don't seem to have any issues like this.

Flags: needinfo?(richard)
Priority: -- → P3
Whiteboard: [tor][fingerprinting][fp-triaged]

I am a bug starter and i am no longer seeing this issue in Firefox. (it disappeared maybe more than a month ago), i am on beta update channel.

Flags: needinfo?(czautohits)

Thanks for letting us know. Let's close this as WORKSFORME then.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Flags: needinfo?(arthur)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.