Closed Bug 1525562 Opened 3 years ago Closed 3 years ago

Newly installed themes are not present and cannot be managed from the Customize page

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1451402
Tracking Status
firefox65 --- affected
firefox66 --- affected
firefox67 --- affected

People

(Reporter: csasca, Unassigned)

Details

Affected versions

  • Firefox 65.0
  • Firefox 66.0b5
  • Nightly 67.0a1

Affected platforms

  • Windows 10 (x64)
  • macOS 10.14
  • Ubuntu 18.04 (x64)

Steps to reproduce

  1. Launch Firefox
  2. Open the Customize page
  3. Select themes and then click on get more themes
  4. Install a random theme and switch back to the customize page

Expected result

  • The newly installed theme can be found and managed in My Themes category in the Customize page.

Actual result

  • The newly installed theme is applied but in My themes, only the standard themes can be found and the Default theme is selected.

Regression range

  • The issue is reproducing across all firefox builds, even on builds where this issue was not reproducing initially.

Additional notes

  • The newly installed themes can be found and managed only under about:addons page.
  • This issue may be caused because of the Customize page not being able to successfully read the themes id's from the AMO.
Component: Theme → Toolbars and Customization

What "random theme" are you using to test?

Flags: needinfo?(catalin.sasca)

:ntim, can you triage this please? I'm assuming this is basically bug 1451402...

Flags: needinfo?(catalin.sasca) → needinfo?(ntim.bugs)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(ntim.bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 1451402
You need to log in before you can comment on or make changes to this bug.