Link then back then link again gives crash

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
critical
VERIFIED WORKSFORME
19 years ago
13 years ago

People

(Reporter: ppandit, Assigned: don)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
using a debug build on Sept. 27 (Windows NT 4.0)

1) Go to a website
2) Click on a link
3) Press BACK
4) Click on a different link
5) CRASH: Unhandled exception in apprunner.exe (NSAPPSHELL.DLL) 0xC0000005
Access Violation.

Here is the trace:
nsHistoryEntry::~nsHistoryEntry() line 199 + 24 bytes
nsHistoryEntry::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsSessionHistory::add(nsSessionHistory * const 0x0429ce30, nsIWebShell *
0x042459a0) line 837 + 28 bytes
nsBrowserInstance::add(nsBrowserInstance * const 0x0429ce9c, nsIWebShell *
0x042459a0) line 1662 + 22 bytes
nsWebShell::LoadURI(nsWebShell * const 0x042459a0, nsIURI * 0x042e70c0, const
char * 0x002cbdd4, nsIInputStream * 0x00000000, int 1, unsigned int 0, const
unsigned int 0, nsISupports * 0x00000000, const unsigned short * 0x042e4be0)
line 2181 + 39 bytes
nsWebShell::LoadURL(nsWebShell * const 0x042459a0, const unsigned short *
0x042e06d0, const char * 0x002cbdd4, nsIInputStream * 0x00000000, int 1,
unsigned int 0, const unsigned int 0, nsISupports * 0x00000000, const unsigned
short * 0x042e4be0) line 2331 + 52 bytes
nsWebShell::LoadURL(nsWebShell * const 0x042459a0, const unsigned short *
0x042e06d0, nsIInputStream * 0x00000000, int 1, unsigned int 0, const unsigned
int 0, nsISupports * 0x00000000, const unsigned short * 0x042e4be0) line 1928
nsWebShell::HandleLinkClickEvent(nsIContent * 0x042a460c, nsLinkVerb
eLinkVerb_Replace, const unsigned short * 0x042e06d0, const unsigned short *
0x10063158 gCommonEmptyBuffer, nsIInputStream * 0x00000000) line 3061
OnLinkClickEvent::HandleEvent() line 2884
HandlePLEvent(OnLinkClickEvent * 0x042e4750) line 2897
PL_HandleEvent(PLEvent * 0x042e4750) line 541 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00d0d3d0) line 500 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000d0238, unsigned int 49506, unsigned int 0,
long 13685712) line 970 + 9 bytes
USER32! DispatchMessageWorker@8 + 135 bytes
USER32! DispatchMessageA@4 + 11 bytes
nsAppShell::Run() line 74
nsAppShellService::Run(nsAppShellService * const 0x00d0d9c0) line 462
main1(int 1, char * * 0x00ca4c70) line 591 + 12 bytes
main(int 1, char * * 0x00ca4c70) line 702 + 13 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! BaseProcessStart@4 + 64 bytes

Updated

19 years ago
Severity: normal → critical

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 1

19 years ago
Par, is this still happening, I can't reproduce. Please try on a more recent
build, thanks.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

19 years ago
Using a debug build from 10/26/99 on Windows NT

No longer getting a crash.

VERIFIED as WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.