Enterprise roots mode should also import Intermediate CAs on MacOS

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P1
normal
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: keeler, Assigned: keeler)

Tracking

(Blocks 1 bug)

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

(Whiteboard: [psm-assigned])

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1473573 +++

Bug 1473573 but for MacOS (what makes this difficult is that the API we need shouldn't be run on the main thread, so we have to introduce a way to do that when the enterprise roots pref changes (on the main thread).

Comment 3

3 months ago
Pushed by dkeeler@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/77eb18940eb1
enterprise certs: differentiate between intermediates and roots on MacOS r=jcj,spohl

Comment 4

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1478826
You need to log in before you can comment on or make changes to this bug.