Remove webgl.bypass-shader-validation

RESOLVED FIXED in Firefox 68

Status

()

enhancement
P1
normal
RESOLVED FIXED
4 months ago
11 days ago

People

(Reporter: jgilbert, Assigned: jgilbert)

Tracking

unspecified
mozilla68
Points:
---

Firefox Tracking Flags

(firefox68 fixed)

Details

(Whiteboard: gfx-noted, crash signature)

Attachments

(1 attachment)

Assignee

Description

4 months ago
No description provided.
Assignee

Comment 1

4 months ago

It's not supported, mostly broken, and unsafe for users to use regularly.
I don't think it has any benefit anymore.

Assignee

Updated

Last month
Duplicate of this bug: 1525857
Assignee

Updated

Last month
Priority: P3 → P1
Crash Signature: [@ mozilla::QueryProgramInfo]
Assignee

Comment 3

Last month

Also remove extra plumbing from WebGLShaderValidator, moved directly
into WebGLShader.

Comment 4

Last month
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ba078373f2c2
Remove webgl.bypass-shader-validation. r=lsalzman

Comment 5

Last month
bugherder
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
See Also: → 1556690
Assignee

Updated

11 days ago
Duplicate of this bug: 1556690
You need to log in before you can comment on or make changes to this bug.