Closed Bug 1526243 Opened 4 years ago Closed 4 years ago

[Linux] Don't use nsGConfService in nsGNOMEShellService.cpp

Categories

(Toolkit :: Startup and Profile System, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox67 --- wontfix
firefox68 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

Details

Attachments

(1 file)

gconf is deprecated and should not be used if GSettings is available.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1433685

Let's handle the nsGNOMEShellService.cpp part here.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: [Linux] Don't use nsGConfService to get/set default browser → [Linux] Don't use nsGConfService in nsGNOMEShellService.cpp
Status: REOPENED → NEW
Assignee: nobody → stransky

Don't use gconf service to get/set default browser as it breaks recent Gnome environment.
Also use XDG_CURRENT_DESKTOP to check actual desktop.

Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/017eefc950b0
[Linux] Don't use nsGConfService in nsGNOMEShellService.cpp, r=glandium

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.