Input type=date error message date format

RESOLVED DUPLICATE of bug 1479427

Status

()

RESOLVED DUPLICATE of bug 1479427
a month ago
a month ago

People

(Reporter: graham.armfield, Unassigned)

Tracking

65 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a month ago

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

Visited a form that contains an input type="date" with max and min value attributes set. Specifically:

<label for="myDate3">Please select a start date</label><br>
<input type="date" id="myDate3" name="myDate3" min="2019-02-06" max="2019-03-05">

I entered a date into the future outside the valid range, and submitted the form.

Actual results:

Firefox showed an error message adjacent to the date input field. Message reads:

"Please select a value that is no later than 2019-03-05"

Note that the date is in a machine readable format that may not be so easily understood by humans.

Expected results:

Firefox should produce a message containing a date in a human readable form - based on my locale settings.

The message should read:
"Please select a value that is no later than 05/03/2019"

I know Firefox could do this as it does correctly interpret default values in the input field into an appropriate value within the control itself.

Although I'm reporting this for Firefox on Windows 10, the same is also true on Firefox for Android.

Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1479427
You need to log in before you can comment on or make changes to this bug.