Clearing "Always use private browsing" flag in the preferences doesn't force a restart (via modal alert dialog box)

VERIFIED FIXED in Firefox 66

Status

()

defect
P1
normal
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

({regression})

Trunk
Firefox 67
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66+ verified, firefox67 verified)

Details

Attachments

(1 attachment)

[Tracking Requested - why for this release]:

See https://bugzilla.mozilla.org/show_bug.cgi?id=1524995#c2

Beta is also affected, and this could potentially leave users (and in-product code) confused about whether they're in private browsing mode or not.

Component: Preferences: Backend → Preferences
Product: Core → Firefox

STR:

  1. clean profile
  2. open about:preferences#privacy
  3. switch to 'use custom settings for history'
  4. turn on 'Always use Private Browsing Mode'
  5. accept the dialog to restart
  6. once restarted, reopen about:preferences#privacy
  7. turn off 'Always use Private Browsing Mode'

ER:
same dialog

AR:
no dialog.

Regression window:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=33ca2ea6b37064d12c0d4fefc81bf689396a5e57&tochange=9ae7ae0acee4f8807cffaf64fef4f2e3a614b997

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2a84cc180ca9
always prompt for restart when toggling permanent private browsing mode, r=jaws
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Comment on attachment 9042838 [details]
Bug 1526793 - always prompt for restart when toggling permanent private browsing mode, r?jaws

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1518252

User impact if declined

This could potentially leave users (and in-product code) confused about whether they're in private browsing mode or not.

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

No

Needs manual test from QE?

Yes

If yes, steps to reproduce

See comment #1

List of other uplifts needed

n/a

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Simple small fix to only the relevant JS so low chance of unintended consequences, comes with automated test to verify it works correctly now

String changes made/needed

n/a

Attachment #9042838 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Whiteboard: [qa-triaged]
Flags: in-testsuite+

I have managed to reproduce the issue using Fx 67.0a1 buildID: 20190204092937.

The issue is verified fixed using latest Fx 67.0a1 (buildID: 20190212195904) on macOS 10.14, Ubuntu 16.04 and Windows 10. After unchecking the "Always use private browsing mode" the user receives the prompt to restart the browser.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

This hasn't been uplifted to beta yet... and beta is definitely affected.

Comment on attachment 9042838 [details]
Bug 1526793 - always prompt for restart when toggling permanent private browsing mode, r?jaws

Fix for confusing state of prefs in PB mode.
Verified in Nightly. OK for uplift for beta 8.

Attachment #9042838 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Coming back with a confirmation for Fx66.0b8 on macOS 10.14, Windows 10 and Ubuntu 18.04. The user is now correctly prompted to restart the browser. This can't be bypassed now by refreshing the page.

QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.