Closed Bug 1527185 Opened 10 months ago Closed 10 months ago

sync does not sync search preferences

Categories

(Firefox :: Sync, defect)

65 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 444284

People

(Reporter: firefox, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

  1. Set up firefox sync
  2. In preferences > Search > Search Bar, select "Add search bar in toolbar", to separate the URL and search fields into 2 fields
  3. Change the default search engine from Google to DDG
  4. Add a new device to firefox Sync, wait for it to Sync

Actual results:

The new device has a unified search+url field. The "Add search bar in toolbar" option was not synced.

The default search engine is Google, not DDG. The default search engine was not synced.

Expected results:

The default search engine should be DDG. The search bar should be separated from the URL bar.

The whole point of using Firefox sync and ticking "Sync settings > preferences" is to set up new devices with the preferences I use on my other devices. Currently this is not the case. I have to go tweak these settings manually.

Component: Untriaged → Sync

Unfortunately, we don't sync any search preferences (including search bar, default search engine, and custom search engines) yet. We've been tracking this over in bug 444284, but don't have a timeline for when we expect to complete that work.

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 444284
You need to log in before you can comment on or make changes to this bug.