Closed Bug 1527389 Opened 7 months ago Closed 3 months ago

The aliases of hidden engines shouldn't show up in the urlbar

Categories

(Firefox :: Address Bar, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox69 --- fixed

People

(Reporter: adw, Assigned: okonaraddi)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 4 obsolete files)

See bug 1526983. If you type @, aliases for hidden engines show up, which probably shouldn't happen. This code controls which aliases appear: https://searchfox.org/mozilla-central/rev/00c0d068ece99717bea7475f7dc07e61f7f35984/toolkit/components/places/PlacesSearchAutocompleteProvider.jsm#93 There's a !engine.hidden check right above that, which should probably be extended to registering aliases too.

Assignee: nobody → okonaraddi
Status: NEW → ASSIGNED
Attachment #9070397 - Attachment is obsolete: true
Attachment #9074567 - Attachment is obsolete: true
Attachment #9074615 - Attachment is obsolete: true
Attachment #9075172 - Attachment is obsolete: true
Pushed by okonaraddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/351504c92d13
The aliases of hidden engines shouldn't show up in the urlbar r=adw
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

I can confirm that this patch works as intended on Firefox Nightly. However wouldn't it be better if instead of solely hiding removed engines, the added ones would be visible as well? In other words if @ would show all the engines from Preferences tab? That solution has been mentioned in a few of the duplicate bugs.

Flags: needinfo?(aryx.bugmail)

Bug 1526983 tracks that.

Flags: needinfo?(aryx.bugmail)
You need to log in before you can comment on or make changes to this bug.