Closed Bug 1527804 Opened 11 months ago Closed 11 months ago

[Wayland] gfx.webrender.all on Wayland displays an empty window for extensions/addons with GDK_BACKEND=wayland

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Crated by Bug 1514156 Comment 38.

I conformed by gecko profiler with "GDK_BACKEND=wayland ./mach run".

Blocks: wayland, wr-linux
Blocks: 1514156
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1508082
Summary: [Wayland] gfx.webrender.all on Wayland displays an empty window for extensions/addons → [Wayland] gfx.webrender.all on Wayland displays an empty window for extensions/addons with GDK_BACKEND=wayland

Bug 1508082 is different bug. Re-open this bug.

This bug only handles the problem that was caused by Bug 1514156.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → sotaro.ikeda.g

Bug 1514156 expects that nsWindow::OnExposeEvent() is called after calling frame_callback_handler(). But it did not happen during opening add-ons(gecko profiler). Then we need to trigger rendering directly from frame_callback_handler() call.

Thanks for the patch, I'll look ta it this week.

Thanks :)

Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/902743b5cc59
Trigger composite from frame_callback_handler() r=stransky
Status: REOPENED → RESOLVED
Closed: 11 months ago11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Blocks: 1508082

Been running FF with wayland and WebRender for 2 days with HiDPI and pretty much all the bleeding edge preview technology possible and I am very impressed how smoothly it runs!
Thanks a lot for fixing bugs!

Depends on: 1531300
You need to log in before you can comment on or make changes to this bug.