Closed Bug 1528159 Opened 7 months ago Closed 7 months ago

Intermittent tests/jit-test/jit-test/tests/gc/weak-marking-01.js | obj2,obj3 (code 3, args "") [0.1 s]

Categories

(Core :: JavaScript Engine, defect, P5)

ARM64
Android
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: pbone)

References

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disable-recommended] [arm64:m3])

Attachments

(2 files)

#[markdown(off)]
Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=228588265&repo=autoland

https://queue.taskcluster.net/v1/task/MeP_Mg4HQ26BHRPXqwoUgQ/runs/0/artifacts/public/logs/live_backing.log

05:53:28 INFO - TEST-PASS | tests/jit-test/jit-test/tests/gc/oomInWeakMap.js | Success (code 59, args "--no-baseline --no-ion --more-compartments") [0.1 s]
05:53:28 INFO - {"action": "test_start", "jitflags": "--no-baseline --no-ion --more-compartments", "pid": 433, "source": "jittests", "test": "gc/oomInWeakMap.js", "thread": "main", "time": 1550210008.39535}
05:53:28 INFO - {"action": "test_end", "extra": {"jitflags": "--no-baseline --no-ion --more-compartments"}, "jitflags": "--no-baseline --no-ion --more-compartments", "message": "Success", "pid": 433, "source": "jittests", "status": "PASS", "test": "gc/oomInWeakMap.js", "thread": "main", "time": 1550210008.498048}
05:53:28 INFO - obj2,obj3
05:53:28 INFO - /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
05:53:28 INFO - Stack:
05:53:28 INFO - weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
05:53:28 INFO - @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1obj2,obj3
05:53:28 INFO - /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
05:53:28 INFO - Stack:
05:53:28 INFO - weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
05:53:28 INFO - @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1Exit code: 3
05:53:28 INFO - FAIL - gc/weak-marking-01.js
05:53:28 WARNING - TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | obj2,obj3 (code 3, args "") [0.1 s]
05:53:28 INFO - {"action": "test_start", "jitflags": "", "pid": 433, "source": "jittests", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1550210008.498769}
05:53:28 INFO - {"action": "test_end", "extra": {"jitflags": ""}, "jitflags": "", "message": "obj2,obj3", "pid": 433, "source": "jittests", "status": "FAIL", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1550210008.601427}
05:53:28 INFO - INFO exit-status : 3
05:53:28 INFO - INFO timed-out : False
05:53:28 INFO - INFO stdout > obj2,obj3
05:53:28 INFO - INFO stdout > /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
05:53:28 INFO - INFO stdout > Stack:
05:53:28 INFO - INFO stdout > weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
05:53:28 INFO - INFO stdout > @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1
05:53:28 INFO - INFO stderr 2> obj2,obj3
05:53:28 INFO - INFO stderr 2> /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
05:53:28 INFO - INFO stderr 2> Stack:
05:53:28 INFO - INFO stderr 2> weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
05:53:28 INFO - INFO stderr 2> @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1
05:53:28 INFO - TEST-PASS | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.3 s]
05:53:28 INFO - {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off --more-compartments", "pid": 433, "source": "jittests", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1550210008.6020868}
05:53:28 INFO - {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off --more-compartments"}, "jitflags": "--ion-eager --ion-offthread-compile=off --more-compartments", "message": "Success", "pid": 433, "source": "jittests", "status": "PASS", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1550210008.905084}
05:53:29 INFO - TEST-PASS | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.4 s]
05:53:29 INFO - {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads", "pid": 433, "source": "jittests", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1550210008.905739}
05:53:29 INFO - {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads"}, "jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads", "message": "Success", "pid": 433, "source": "jittests", "status": "PASS", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1550210009.308821}
05:53:29 INFO - TEST-PASS | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | Success (code 0, args "--baseline-eager") [0.6 s]
05:53:29 INFO - {"action": "test_start", "jitflags": "--baseline-eager", "pid": 433, "source": "jittests", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1550210009.3094652}
05:53:29 INFO - {"action": "test_end", "extra": {"jitflags": "--baseline-eager"}, "jitflags": "--baseline-eager", "message": "Success", "pid": 433, "source": "jittests", "status": "PASS", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1550210009.912785}
05:53:30 INFO - obj2,obj3
05:53:30 INFO - /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
05:53:30 INFO - Stack:
05:53:30 INFO - weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
05:53:30 INFO - @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1obj2,obj3
05:53:30 INFO - /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
05:53:30 INFO - Stack:
05:53:30 INFO - weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
05:53:30 INFO - @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1Exit code: 3
05:53:30 INFO - FAIL - gc/weak-marking-01.js
05:53:30 WARNING - TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | obj2,obj3 (code 3, args "--no-baseline --no-ion --more-compartments") [0.3 s]
05:53:30 INFO - {"action": "test_start", "jitflags": "--no-baseline --no-ion --more-compartments", "pid": 433, "source": "jittests", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1550210009.913526}

Probably because of Bug 1433007

Blocks: 1433007
OS: Unspecified → Android
Hardware: Unspecified → ARM64

I think I see the problem, with a smaller nursery the test starts a GC early, which confuses the testing code.

So it's a matter of changing the values in the test so that it doesn't GC quite so early. Or adding a new zeal mode that sets an exact nursery size to make this and other tests more predictable. The benefit of an extra zeal mode is that it prevents other tests from breaking in similar ways for future changes, is that worth-while? sfink?

Flags: needinfo?(sphink)
Whiteboard: [stockwell needswork:owner]

I think it's a very good idea to enforce a nursery size. I'm not sure about implementing it as a zeal mode, though. Those are all about the timing of GC slices, and heap verification passes.

We already have a gcparam("maxNurseryBytes", N). Maybe add either "minNurseryBytes" or "fixedNurserySize"? What seems best to you?

Flags: needinfo?(sphink)

(In reply to Steve Fink [:sfink] [:s:] from comment #6)

I think it's a very good idea to enforce a nursery size. I'm not sure about implementing it as a zeal mode, though. Those are all about the timing of GC slices, and heap verification passes.

We already have a gcparam("maxNurseryBytes", N).

Doh, I should ahve thought of that.

Maybe add either "minNurseryBytes" or "fixedNurserySize"? What seems best to you?

I'll take a look at the code for maxNurseryBytes and deside what fits best.

Cheers.

There are 104 failures in the last 7 days.
::pbone , should we disable it until you`ll fix the issue?

Flags: needinfo?(pbone)

I'm working on it now and should have a patch by the end of the day. It's up to you if you disable it.

Flags: needinfo?(pbone)

make that the end of the week, Bug 1530583 is a dependency

Assignee: nobody → pbone
Status: NEW → ASSIGNED
Depends on: 1530583

(In reply to Paul Bone [:pbone] from comment #13)

I'm working on it now and should have a patch by the end of the day. It's up to you if you disable it.

We interfere and disable tests only if we don't receive a reply from the developer or if he specifically asks to disable the test as a solution to fixing the bug in question.

There are 152 total failures in the last 7 days on android-hw-p2-8-0-android-aarch64 opt

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=230906144&repo=mozilla-inbound&lineNumber=3100

00:58:17 INFO - TEST-PASS | tests/jit-test/jit-test/tests/gc/oomInWeakMap.js | Success (code 59, args "--no-baseline --no-ion --more-compartments") [0.1 s]
00:58:17 INFO - {"action": "test_start", "jitflags": "--no-baseline --no-ion --more-compartments", "pid": 436, "source": "jittests", "test": "gc/oomInWeakMap.js", "thread": "main", "time": 1551315497.0364351}
00:58:17 INFO - {"action": "test_end", "extra": {"jitflags": "--no-baseline --no-ion --more-compartments"}, "jitflags": "--no-baseline --no-ion --more-compartments", "message": "Success", "pid": 436, "source": "jittests", "status": "PASS", "test": "gc/oomInWeakMap.js", "thread": "main", "time": 1551315497.140655}
00:58:17 INFO - obj2,obj3
00:58:17 INFO - /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
00:58:17 INFO - Stack:
00:58:17 INFO - weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
00:58:17 INFO - @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1obj2,obj3
00:58:17 INFO - /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
00:58:17 INFO - Stack:
00:58:17 INFO - weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
00:58:17 INFO - @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1Exit code: 3
00:58:17 INFO - FAIL - gc/weak-marking-01.js
00:58:17 WARNING - TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | obj2,obj3 (code 3, args "") [0.2 s]
00:58:17 INFO - {"action": "test_start", "jitflags": "", "pid": 436, "source": "jittests", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1551315497.141885}
00:58:17 INFO - {"action": "test_end", "extra": {"jitflags": ""}, "jitflags": "", "message": "obj2,obj3", "pid": 436, "source": "jittests", "status": "FAIL", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1551315497.346472}
00:58:17 INFO - INFO exit-status : 3
00:58:17 INFO - INFO timed-out : False
00:58:17 INFO - INFO stdout > obj2,obj3
00:58:17 INFO - INFO stdout > /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
00:58:17 INFO - INFO stdout > Stack:
00:58:17 INFO - INFO stdout > weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
00:58:17 INFO - INFO stdout > @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1
00:58:17 INFO - INFO stderr 2> obj2,obj3
00:58:17 INFO - INFO stderr 2> /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
00:58:17 INFO - INFO stderr 2> Stack:
00:58:17 INFO - INFO stderr 2> weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
00:58:17 INFO - INFO stderr 2> @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1
00:58:17 INFO - TEST-PASS | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.3 s]
00:58:17 INFO - {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off --more-compartments", "pid": 436, "source": "jittests", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1551315497.347571}
00:58:17 INFO - {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off --more-compartments"}, "jitflags": "--ion-eager --ion-offthread-compile=off --more-compartments", "message": "Success", "pid": 436, "source": "jittests", "status": "PASS", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1551315497.652154}
00:58:18 INFO - TEST-PASS | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.4 s]
00:58:18 INFO - {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads", "pid": 436, "source": "jittests", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1551315497.6531851}
00:58:18 INFO - {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads"}, "jitflags": "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads", "message": "Success", "pid": 436, "source": "jittests", "status": "PASS", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1551315498.057934}
00:58:18 INFO - TEST-PASS | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | Success (code 0, args "--baseline-eager") [0.7 s]
00:58:18 INFO - {"action": "test_start", "jitflags": "--baseline-eager", "pid": 436, "source": "jittests", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1551315498.058948}
00:58:18 INFO - {"action": "test_end", "extra": {"jitflags": "--baseline-eager"}, "jitflags": "--baseline-eager", "message": "Success", "pid": 436, "source": "jittests", "status": "PASS", "test": "gc/weak-marking-01.js", "thread": "main", "time": 1551315498.764216}
00:58:19 INFO - obj2,obj3
00:58:19 INFO - /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
00:58:19 INFO - Stack:
00:58:19 INFO - weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
00:58:19 INFO - @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1obj2,obj3
00:58:19 INFO - /data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3 Error: Incremental GC already in progress
00:58:19 INFO - Stack:
00:58:19 INFO - weakKeysRealloc@/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:127:3
00:58:19 INFO - @/data/local/tests/jit-tests/jit-tests/tests/gc/weak-marking-01.js:132:1Exit code: 3
00:58:19 INFO - FAIL - gc/weak-marking-01.js
00:58:19 WARNING - TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/gc/weak-marking-01.js | obj2,obj3 (code 3, args "--no-baseline --no-ion --more-compartments") [0.3 s]

Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]
Duplicate of this bug: 1530583

What we think is happening here is because the nursery is now smaller a full GC begins sooner and has not completed at the call to startgc()

Avoid assertion failures with this test by adding finishgc() calls.

Add finisgc() shell builtin functions.

The patch more-or-less works around the problem, which is fine.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=82e42f1c1a88fd7b2a00023d86083262b74b1014

But I'm also concerned that because a collection happens before we call startgc() that the test no-longer tests what it thinks its testing - I've not looked too deeply. But to fix that we would need to add a minimum nursery size control (Bug 1531626) which is a good idea anyway.

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dab1f2af9040
Add finishgc() calls before each startgc() call r=sfink
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1519085
Whiteboard: [stockwell disable-recommended] → [stockwell disable-recommended] [arm64:m3]
Pushed by pbone@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d1e0b848dfca
Fix the nursery size to make a test more reliable r=sfink

Backed out 6 changesets (bug 1528159, bug 1531626) for mozcrash.py - spidermonkey

Backout: https://hg.mozilla.org/integration/autoland/rev/91578d6aeae5509fc238450943e8a11d0c7492ee

Failure push: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=235352629&
revision=d1e0b848dfcaf4387201fa2807eb807279f369e0

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=235352629&repo=autoland&lineNumber=4447

[task 2019-03-22T04:30:55.282Z] TEST-PASS | testGCStoreBufferRAssertion failure: false (tunables.setParameter(JSGC_MAX_NURSERY_BYTES, maxNurseryBytes, lock)), at /builds/worker/workspace/build/src/js/src/gc/GC.cpp:1265
[task 2019-03-22T04:30:55.298Z] in directory /builds/worker/workspace/build/src/obj-spider, running ['/builds/worker/workspace/build/src/obj-spider/_virtualenvs/init/bin/python', '/builds/worker/workspace/build/src/testing/mozbase/mozcrash/mozcrash/mozcrash.py', '/tmp', '/builds/worker/workspace/build/src/obj-spider/dist/crashreporter-symbols']
[task 2019-03-22T04:30:55.375Z] mozcrash INFO | Copy/paste: /builds/worker/workspace/breakpad-tools/minidump_stackwalk /tmp/ed98e438-3d2f-4b28-1b6e32b7-8104aec8.dmp /builds/worker/workspace/build/src/obj-spider/dist/crashreporter-symbols
[task 2019-03-22T04:30:56.466Z] mozcrash INFO | Saved minidump as /builds/worker/ed98e438-3d2f-4b28-1b6e32b7-8104aec8.dmp
[task 2019-03-22T04:30:56.466Z] PROCESS-CRASH | mozcrash.py | application crashed [@ js::gc::GCRuntime::init]
[task 2019-03-22T04:30:56.466Z] Crash dump filename: /tmp/ed98e438-3d2f-4b28-1b6e32b7-8104aec8.dmp
[task 2019-03-22T04:30:56.466Z] Operating system: Linux
[task 2019-03-22T04:30:56.466Z] 0.0.0 Linux 4.4.0-1014-aws #14taskcluster1-Ubuntu SMP Tue Apr 3 10:27:00 UTC 2018 x86_64
[task 2019-03-22T04:30:56.466Z] CPU: amd64
[task 2019-03-22T04:30:56.466Z] family 6 model 63 stepping 2
[task 2019-03-22T04:30:56.466Z] 16 CPUs
[task 2019-03-22T04:30:56.466Z]
[task 2019-03-22T04:30:56.466Z] GPU: UNKNOWN
[task 2019-03-22T04:30:56.466Z]
[task 2019-03-22T04:30:56.466Z] Crash reason: SIGSEGV
[task 2019-03-22T04:30:56.466Z] Crash address: 0x0
[task 2019-03-22T04:30:56.466Z] Process uptime: not available
[task 2019-03-22T04:30:56.466Z]
[task 2019-03-22T04:30:56.466Z] Thread 0 (crashed)
[task 2019-03-22T04:30:56.467Z] 0 jsapi-tests!js::gc::GCRuntime::init [GC.cpp:d1e0b848dfcaf4387201fa2807eb807279f369e0 : 1264 + 0x0]
[task 2019-03-22T04:30:56.467Z] rax = 0x0000555557cd8800 rdx = 0x0000000000000000
[task 2019-03-22T04:30:56.467Z] rcx = 0x0000555556d30388 rbx = 0x00007ffff4ff96b8
[task 2019-03-22T04:30:56.467Z] rsi = 0x0000000000000000 rdi = 0x00007ffff70df880
[task 2019-03-22T04:30:56.467Z] rbp = 0x00007fffffffdf90 rsp = 0x00007fffffffdf10
[task 2019-03-22T04:30:56.467Z] r8 = 0x00007ffff7e00ca0 r9 = 0x0000000000000001
[task 2019-03-22T04:30:56.467Z] r10 = 0x0000000000000000 r11 = 0x00007ffff6dbeea0
[task 2019-03-22T04:30:56.467Z] r12 = 0x00007fffffffdf30 r13 = 0x0000000000100001
[task 2019-03-22T04:30:56.467Z] r14 = 0x0000000000020000 r15 = 0x0000000000020000
[task 2019-03-22T04:30:56.467Z] rip = 0x00005555560afce9
[task 2019-03-22T04:30:56.467Z] Found by: given as instruction pointer in context
[task 2019-03-22T04:30:56.467Z] 1 jsapi-tests!JSRuntime::init [Runtime.cpp:d1e0b848dfcaf4387201fa2807eb807279f369e0 : 206 + 0x12]
[task 2019-03-22T04:30:56.467Z] rbp = 0x00007fffffffe000 rsp = 0x00007fffffffdfa0
[task 2019-03-22T04:30:56.467Z] rip = 0x0000555555dd53c5
[task 2019-03-22T04:30:56.467Z] Found by: previous frame's frame pointer
[task 2019-03-22T04:30:56.467Z] 2 jsapi-tests!js::NewContext [JSContext.cpp:d1e0b848dfcaf4387201fa2807eb807279f369e0 : 159 + 0x11]
[task 2019-03-22T04:30:56.467Z] rbp = 0x00007fffffffe050 rsp = 0x00007fffffffe010
[task 2019-03-22T04:30:56.467Z] rip = 0x0000555555d08006
[task 2019-03-22T04:30:56.467Z] Found by: previous frame's frame pointer
[task 2019-03-22T04:30:56.467Z] 3 jsapi-tests!cls_testGCOutOfMemory::createContext [testGCOutOfMemory.cpp:d1e0b848dfcaf4387201fa2807eb807279f369e0 : 61 + 0x5]
[task 2019-03-22T04:30:56.467Z] rbp = 0x00007fffffffe070 rsp = 0x00007fffffffe060
[task 2019-03-22T04:30:56.467Z] rip = 0x0000555555815a3a
[task 2019-03-22T04:30:56.467Z] Found by: previous frame's frame pointer
[task 2019-03-22T04:30:56.467Z] 4 jsapi-tests!JSAPITest::init [tests.cpp:d1e0b848dfcaf4387201fa2807eb807279f369e0 : 18 + 0x2]
[task 2019-03-22T04:30:56.467Z] rbp = 0x00007fffffffe090 rsp = 0x00007fffffffe080
[task 2019-03-22T04:30:56.467Z] rip = 0x0000555555989a52
[task 2019-03-22T04:30:56.467Z] Found by: previous frame's frame pointer
[task 2019-03-22T04:30:56.467Z] 5 jsapi-tests!main [tests.cpp:d1e0b848dfcaf4387201fa2807eb807279f369e0 : 123 + 0x9]
[task 2019-03-22T04:30:56.467Z] rbp = 0x00007fffffffe110 rsp = 0x00007fffffffe0a0
[task 2019-03-22T04:30:56.467Z] rip = 0x000055555573b3a0
[task 2019-03-22T04:30:56.467Z] Found by: previous frame's frame pointer
[task 2019-03-22T04:30:56.467Z] 6 jsapi-tests!_GLOBAL__sub_I_WasmStubs.cpp [RegisterSets.h:d1e0b848dfcaf4387201fa2807eb807279f369e0 : 339 + 0x5]
[task 2019-03-22T04:30:56.467Z] rbp = 0x00007fffffffe110 rsp = 0x00007fffffffe0c0
[task 2019-03-22T04:30:56.467Z] rip = 0x000055555573d228
[task 2019-03-22T04:30:56.467Z] Found by: stack scanning
[task 2019-03-22T04:30:56.467Z] 7 libc-2.13.so + 0xfc48
[task 2019-03-22T04:30:56.467Z] rbp = 0x00007fffffffe110 rsp = 0x00007fffffffe0e8
[task 2019-03-22T04:30:56.467Z] rip = 0x00007ffff6d67c48
[task 2019-03-22T04:30:56.467Z] Found by: stack scanning
[task 2019-03-22T04:30:56.467Z] 8 libc-2.13.so + 0x1eead
[task 2019-03-22T04:30:56.467Z] rsp = 0x00007fffffffe120 rip = 0x00007ffff6d76ead
[task 2019-03-22T04:30:56.467Z] Found by: stack scanning
[task 2019-03-22T04:30:56.467Z] 9 jsapi-tests + 0x1e72b0
[task 2019-03-22T04:30:56.467Z] rsp = 0x00007fffffffe140 rip = 0x000055555573b2b0
[task 2019-03-22T04:30:56.467Z] Found by: stack scanning

Flags: needinfo?(pbone)

The problem will be on Bug 1531626

Flags: needinfo?(pbone)
Pushed by pbone@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bb215d1a9f3b
Fix the nursery size to make a test more reliable r=sfink
You need to log in before you can comment on or make changes to this bug.