Closed Bug 15286 Opened 20 years ago Closed 16 years ago

selection needs to swap highlight foreground/background color based on background color

Categories

(Core :: DOM: Selection, defect, P4)

x86
Windows NT
defect

Tracking

()

RESOLVED DUPLICATE of bug 56314

People

(Reporter: buster, Assigned: mjudge)

References

()

Details

Nav 4 has an algorithm that will swap foreground and background highlight color
if the background highlight and the document background color are within a small
tolerance of each other.  This allows the selection to be visible regardless of
the background.
buster, could you possibly provide a URL in which this is an issue? (I thought
we're doing correctly what you're referring to --- e.g. how does this differ from
9960 or 13831?)

Thanks!
this is probably a dup of 13831 or 9960
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
I'm guessing that buster@netscape.com intended this to be dup'ed of #9960 (which
has been marked fixed) which is for xor'ing the selection.  Please re-open if you
intended this bug to be something else.


*** This bug has been marked as a duplicate of 9960 ***
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
No, this is meant for something else. The issue is when selection code uses
style data for selection colors it still needs to detect foreground/bachground
collisions and swap foreground/background (not xor).
Status: REOPENED → ASSIGNED
Target Milestone: M15
setting to M15, this can wait until after the beta push
*** Bug 25622 has been marked as a duplicate of this bug. ***
Priority: P3 → P4
until the spec in CSS3 allows us to use this system of letting the OS decide 
what the colors are depending on the current foreground and background I am 
leaving the deciding of color to CSS3.  This will probably mean that the DEFAULT 
style of CSS will be the default foreground andbackground of the OS. then any 
page that wishes to override this can do so.  Until CSS3 has some specs on how 
to in a XP way allow the system to be handed the current color and style then 
return the new background and foreground color, this will be the case. no XOR 
for now in other words.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
*SPAM*: Changing the QA contact of all open/resolved Selection bugs from 
elig@netscape.com to BlakeR1234@aol.com.  After the many great years of service 
Eli has given to Mozilla, it's time for him to move on; he has accepted a 
position at Eazel.  We'll be sad to see him go, and I'll do my best to fill his 
spot...
QA Contact: elig → BlakeR1234
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

*** This bug has been marked as a duplicate of 56314 ***
Status: REOPENED → RESOLVED
Closed: 20 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.