Closed Bug 1528685 Opened 3 years ago Closed 3 years ago

Crash in [@ mozilla::PresShell::ContentStateChanged]

Categories

(Core :: Layout, defect)

Unspecified
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1528613

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-a9962809-2d79-4f14-8362-a56700190217.

Top 10 frames of crashing thread:

0 xul.dll void mozilla::PresShell::ContentStateChanged layout/base/PresShell.cpp:4232
1 xul.dll mozilla::dom::Document::ContentStateChanged dom/base/Document.cpp:4948
2 xul.dll mozilla::dom::HTMLFormElement::UpdateValidity dom/html/HTMLFormElement.cpp:1928
3 xul.dll mozilla::dom::HTMLInputElement::UpdateAllValidityStatesButNotElementState dom/html/HTMLInputElement.cpp:6673
4 xul.dll void mozilla::dom::HTMLInputElement::OnValueChanged dom/html/HTMLInputElement.cpp:6759
5 xul.dll nsTextEditorState::SetValue dom/html/nsTextEditorState.cpp:2459
6 xul.dll nsTextEditorState::UnbindFromFrame dom/html/nsTextEditorState.cpp:2036
7 xul.dll void nsTextControlFrame::DestroyFrom layout/forms/nsTextControlFrame.cpp:139
8 xul.dll nsBlockFrame::DoRemoveFrameInternal layout/generic/nsBlockFrame.cpp:5765
9 xul.dll nsBlockFrame::RemoveFrame layout/generic/nsBlockFrame.cpp:5137

Note that there are crashes with the same signature for older versions but they're unrelated. This crash seem to have appeared in nightly recently and has identical stacks on both Windows and Linux.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1528613
You need to log in before you can comment on or make changes to this bug.