Closed Bug 1528686 Opened 3 years ago Closed 3 years ago

Slotted custom elements with focusable shadow root content misplace focus

Categories

(Core :: DOM: Core & HTML, defect)

65 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox65 --- affected
firefox66 --- unaffected
firefox67 --- unaffected

People

(Reporter: virkki, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.109 Safari/537.36

Steps to reproduce:

  1. Open: https://jsbin.com/niwosobapi/edit
  2. Focus the first input
  3. Hit tab

Actual results:

The focus is somewhere it shouldn't be

Expected results:

The second input is focused

Hi @Virkki, I've tested this issue on several machines: Mac OS X, Ubuntu 16.04 and Windows 10 - and Firefox versions: latest nightly 67.0a1, beta 66.0b10 and release 65.0.1.

The issue can be reproduced on all machine OS'es only on release version 65.0.1
Thanks for your contribution.

Status: UNCONFIRMED → NEW
Component: Untriaged → Keyboard: Navigation
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All

I also confirmed that this issue is invalid on the latest nightly 67.
We have fixed several shadow dom focus issues before, such as https://bugzilla.mozilla.org/show_bug.cgi?id=1500273

Dear reporter, since this is fixed on the latest version, I'll close this bug. Thank you.

Blocks: shadowdom
Status: NEW → RESOLVED
Closed: 3 years ago
Component: Keyboard: Navigation → DOM: Core & HTML
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.