Closed Bug 1528891 Opened 2 years ago Closed 7 months ago

Windows workers use the wrong path for checkout cache

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1527313

People

(Reporter: glandium, Unassigned)

References

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → mh+mozilla

On docker-worker and mac, checkout caches are in a separate directory
from the workspace. It also happens that the current setup makes the
checkout caches actually unused, and that's a good thing, considering
builds happening on docker-worker currently fill the source directory
with build artifacts.

However, on Windows, the current setup is such that the source directory
and build artifacts are all part of the checkout cache location, which,
if caches were enabled, would make all windows builds share their
objdir, which would not work quite well when building e.g. beta after
central, or debug after opt, for that matter (since all build types
share checkout caches).

As a matter of fact, one reason enabling caches failed is that because
the objdir is part of the directory, the size of the data to be cached
was tremendous.

Considering the mess there is to untangle to fix this, and my todo list, I won't be putting more time into this.

Assignee: mh+mozilla → nobody

This ended up being fixed as part of Bug 1519472.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1519472

Actually in Bug 1527313.

Duplicate of bug: 1527313
You need to log in before you can comment on or make changes to this bug.