Closed Bug 1529225 Opened 9 months ago Closed 9 months ago

Failed prop type: The prop `filterBarVisible` is marked as required in `FilterBar`

Categories

(DevTools :: Console, defect, P3)

defect

Tracking

(firefox67 fixed)

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: Honza, Assigned: koroknay)

References

Details

(Whiteboard: [good first verify])

Attachments

(1 file)

STR:

  1. Load https://legalvision.com.au/
  2. Open Browser Console
  3. Check the warning:

Failed prop type: The prop filterBarVisible is marked as required in FilterBar

Warning: Failed prop type: The prop filterBarVisible is marked as required in FilterBar, but its value is undefined.
in FilterBar (created by Connect(FilterBar))
in Connect(FilterBar) (created by App)
in div (created by App)
in div (created by App)
in App
in VisibilityHandler
in Unknown (created by Connect(Component))
in Connect(Component)
in Provider react-dev.js:369:15
printWarning resource://devtools/client/shared/vendor/react-dev.js:369
warning resource://devtools/client/shared/vendor/react-dev.js:393
checkPropTypes resource://devtools/client/shared/vendor/react-dev.js:1423
validatePropTypes resource://devtools/client/shared/vendor/react-dev.js:1627
createElementWithValidation resource://devtools/client/shared/vendor/react-dev.js:1715
render Redux
finishClassComponent resource://devtools/client/shared/vendor/react-dom-dev.js:13771
updateClassComponent resource://devtools/client/shared/vendor/react-dom-dev.js:13733
beginWork resource://devtools/client/shared/vendor/react-dom-dev.js:14402
performUnitOfWork resource://devtools/client/shared/vendor/react-dom-dev.js:16441
workLoop resource://devtools/client/shared/vendor/react-dom-dev.js:16480
renderRoot resource://devtools/client/shared/vendor/react-dom-dev.js:16520
performWorkOnRoot resource://devtools/client/shared/vendor/react-dom-dev.js:17138
performWork resource://devtools/client/shared/vendor/react-dom-dev.js:17060
performSyncWork resource://devtools/client/shared/vendor/react-dom-dev.js:17032
requestWork resource://devtools/client/shared/vendor/react-dom-dev.js:16932
scheduleWork$1 resource://devtools/client/shared/vendor/react-dom-dev.js:16796
scheduleRootUpdate resource://devtools/client/shared/vendor/react-dom-dev.js:17363
updateContainerAtExpirationTime resource://devtools/client/shared/vendor/react-dom-dev.js:17390
updateContainer resource://devtools/client/shared/vendor/react-dom-dev.js:17417
render resource://devtools/client/shared/vendor/react-dom-dev.js:17700
legacyRenderSubtreeIntoContainer resource://devtools/client/shared/vendor/react-dom-dev.js:17840
unbatchedUpdates resource://devtools/client/shared/vendor/react-dom-dev.js:17257
legacyRenderSubtreeIntoContainer resource://devtools/client/shared/vendor/react-dom-dev.js:17836
render resource://devtools/client/shared/vendor/react-dom-dev.js:17895
init resource://devtools/client/webconsole/webconsole-wrapper.js:333
init resource://devtools/client/webconsole/webconsole-wrapper.js:51
init resource://devtools/client/webconsole/webconsole-ui.js:66
init resource://devtools/client/webconsole/webconsole.js:105
init resource://devtools/client/webconsole/browser-console.js:71
openBrowserConsole resource://devtools/client/webconsole/hudservice.js:101
_browserConsoleInitializing resource://devtools/client/webconsole/hudservice.js:161
toggleBrowserConsole resource://devtools/client/webconsole/hudservice.js:163
openBrowserConsoleOrFocus resource://devtools/client/webconsole/hudservice.js:180
onKeyShortcut resource://devtools/client/framework/devtools-browser.js:274
onKey resource:///modules/DevToolsStartup.jsm:606
xulKey resource:///modules/DevToolsStartup.jsm:583
createKey resource:///modules/DevToolsStartup.jsm:630
hookKeyShortcuts resource:///modules/DevToolsStartup.jsm:583
hookWindow resource:///modules/DevToolsStartup.jsm:357
onWindowReady resource:///modules/DevToolsStartup.jsm:296
_delayedStartup chrome://browser/content/browser.js:1606
onLoad chrome://browser/content/browser.js:1428
<anonymous> chrome://browser/content/browser.xul:106

Looks like the feature to hide the FilterBar was removed in Bug 1523861, but the component and mocha tests were not updated.

Martin: would you be interested in this small follow-up bug related to the bug you fixed a few weeks ago?

We should:

Note that the mocha test dedicated to the FilterBar is also outdated. But I am not sure if the mochatest suite is maintained at the moment, so we can leave this out of this bug.

Flags: needinfo?(koroknay)

Hi, sure, happy to take this on!

Flags: needinfo?(koroknay)

Great, I am assigning the bug to you :) I checked with :nchevobbe and he confirmed that the mocha tests are not really up to date at the moment, so no need to update devtools/client/webconsole/test/components/filter-bar.test.js

Assignee: nobody → koroknay
Severity: normal → enhancement
Status: NEW → ASSIGNED
Priority: -- → P3

Removed the 'filterBarVisible' required prop from the FilterBar component, which is no longer needed after the changes in Bug 1523861.

(In reply to Julian Descottes [:jdescottes] from comment #4)

Done :)

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3d232ae48e3d
Remove unused filterBarVisible prop from FilterBar component. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.