Closed Bug 1529383 Opened 4 years ago Closed 4 years ago

Finalize WebRTC plan and end-user experience for Windows ARM64 MVP build

Categories

(Core :: WebRTC, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1530488
Tracking Status
firefox66 + fixed
firefox67 --- fixed

People

(Reporter: ritu, Assigned: dminor)

References

(Blocks 1 open bug)

Details

Chuck mentioned that WebRTC is fully blocked on the Windows 19h1 update. Instead of leaving the WebRTC scenarios in a half-baked state, we could disable WebRTC on the ARM64 MVP build for M2 milestone.

Hi Nils, Chuck, this is the bug to track disabling WebRTC for MVP build.

Flags: needinfo?(drno)
Flags: needinfo?(charmston)

Technically what is not working on ARM64 is camera access. So WebRTC's PeerConnection's including audio via the microphone and data channels do work fine without Windows 19h1.

But I don't think we have a pref to simply turn off all camera access. The next best thing is a build time option to disable building webrtc AFAIK.

Dan I only found https://searchfox.org/mozilla-central/rev/4587d146681b16ff9878a6fdcba53b04f76abe1d/build/gyp_includes/common.gypi#313
But I'm not sure if that is really the option to turn off webrtc at build time. Do you know where/how to turn it off?

Flags: needinfo?(drno) → needinfo?(dminor)

I forgot to mention that Dan is also going to look into the possibility to port over camera access code based on Media Foundation from Chrome, which should work before 19h1. So if that doesn't require major surgery and works we still might be able to leave webrtc turned on.

(In reply to Nils Ohlmeier [:drno] from comment #2)

Technically what is not working on ARM64 is camera access. So WebRTC's PeerConnection's including audio via the microphone and data channels do work fine without Windows 19h1.

We need to do whatever is least terrible, but not put too much work into it.

(In reply to Nils Ohlmeier [:drno] from comment #3)

I forgot to mention that Dan is also going to look into the possibility to port over camera access code based on Media Foundation from Chrome, which should work before 19h1. So if that doesn't require major surgery and works we still might be able to leave webrtc turned on.

That would be nice. It is hard to predict how Microsoft will roll out 19h1.

You need to add

ac_add_options --disable-webrtc

to a mozconfig. From the comments in that file, it looks like adding it to browser/config/mozconfigs/win64-aarch64/common-win64 would disable it for all windows aarch64 builds.

I can put together a patch, but if it is alright, I'll take a quick look at the MediaFoundation camera capture code first.

Flags: needinfo?(dminor)

I don't think there's any action items on me here, so I'm moving myself to CC.

Flags: needinfo?(charmston)
Depends on: 1530488

I'll take this bug for now, but I think we'll end up just disabling the camera over in Bug 1530488 rather than all of WebRTC.

Assignee: nobody → dminor
Rank: 15
Priority: -- → P2
Summary: Disable WebRTC for Windows ARM64 MVP build → Finalize WebRTC plan and end-user experience for Windows ARM64 MVP build

From the QA work done on Bug 1530488 it sounds like that is a workable solution for the MVP. I'm going to resolve this as a duplicate of that bug. Please re-open if we should reconsider.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE

I just realized that this is blocking 66 uplift and Bug 1530488 is only on 67. It has been left late, but should I request uplift on 1530488 for 66?

Flags: needinfo?(charmston)

I do think this will need to be uplifted to 66. That was the whole point of filing this bug. :(

Let's do it!

Flags: needinfo?(charmston)

Hi Liz, we need the fix for bug 1530488 in 66, it's an ARM64 only fix needed for QC MVP. I filed this bug to track that work but the actual fix was made in a different bug.

Flags: needinfo?(lhenry)

Tracking that in bug 1530488.

Flags: needinfo?(lhenry)

(In reply to Ritu Kothari (:ritu) from comment #10)

I do think this will need to be uplifted to 66. That was the whole point of filing this bug. :(

I'm sorry, that was my mistake, I thought the MVP was targeting 67.

You need to log in before you can comment on or make changes to this bug.