Closed Bug 1529681 Opened 7 months ago Closed 6 months ago

Build error: failed to run custom build command for `style v0.0.1

Categories

(Core :: CSS Parsing and Computation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: farre, Assigned: emilio)

References

(Depends on 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

No description provided.
Assignee: nobody → afarre
Assignee: afarre → nobody
Attached patch 0002-wip.patch (obsolete) — Splinter Review
Flags: needinfo?(emilio)

Stack of the crash:

(rr) bt
#0  0x00007f9932d457a0 in clang::ASTContext::getTypeInfoImpl(clang::Type const*) const () from /lib64/libclangAST.so.7
#1  0x00007f9932d40c2b in clang::ASTContext::getTypeInfo(clang::Type const*) const () from /lib64/libclangAST.so.7
#2  0x00007f9932d44275 in clang::ASTContext::getTypeInfoInChars(clang::Type const*) const () from /lib64/libclangAST.so.7
#3  0x00007f9932d4432d in clang::ASTContext::getTypeSizeInChars(clang::QualType) const () from /lib64/libclangAST.so.7
#4  0x00007f99330ef508 in clang_Type_getSizeOf () from /usr/lib64/libclang.so.7
#5  0x000055d9c40ec826 in clang_sys::clang_Type_getSizeOf (type_=...) at /home/emilio/.cargo/registry/src/github.com-1ecc6299db9ec823/clang-sy
   s-0.26.4/src/link.rs:98
#6  0x000055d9c3d498b3 in bindgen::clang::Type::fallible_size (self=0x7ffdd0d65530) at src/clang.rs:945
#7  0x000055d9c3d49a3c in bindgen::clang::Type::fallible_layout (self=0x7ffdd0d65530) at src/clang.rs:978
#8  0x000055d9c3e13968 in bindgen::ir::ty::Type::from_clang_ty (potential_id=..., ty=0x7ffdd0d65530, location
m=..., parent_id=..., ctx=0x7ffdd0d65ed8) at src/ir/ty.rs:733
#9  0x000055d9c3ea3767 in <bindgen::ir::item::Item as bindgen::parse::ClangItemParser>::from_ty_with_id (id=..., ty=0x7ffdd0d65530, lo
    cation=..., parent_id=..., ctx=0x7ffdd0d65ed8) at src/ir/item.rs:1573

I have a standalone test-case, I'll run creduce on it and report (maybe fix?) an llvm bug.

The type its crashing is an auto type, so I suspect clang is crashing when trying to infer the type of the Tie return value.

Well, actually no need to run creduce, it crashes with the following input:

struct void_t;

class BrowsingContext {
  auto Tie(void_t& aUnused) const;
};

Running it on an LLVM debug build reports:

/home/emilio/src/llvm-project/clang/lib/AST/ASTContext.cpp:2052: clang::TypeInfo clang::ASTContext::getTypeInfoImpl(const clang::Type *) const: Assertion `!A->getDeducedType().isNull() && "cannot request the size of an undeduced or dependent auto type"' failed.

Filed https://bugs.llvm.org/show_bug.cgi?id=40813, got a patch for libclang. I'll also write a bindgen workaround.

I guess I can assign it to me :)

Assignee: nobody → emilio

https://github.com/rust-lang/rust-bindgen/pull/1525 is the bindgen workaround, I'll use this bug to update bindgen.

Flags: needinfo?(emilio)

This works around an LLVM bug and also pulls a fair amount of bugfixes and perf
improvements. None of the breaking changes affect either the style system or
cranelift stuff.

Changelog for convenience:

https://github.com/rust-lang/rust-bindgen/compare/v0.43.2...v0.47.2

Attachment #9045736 - Attachment is obsolete: true
Attachment #9045737 - Attachment is obsolete: true
Component: DOM → CSS Parsing and Computation
Priority: -- → P3

https://github.com/alexcrichton/backtrace-rs/issues/160. Given this was introduced via the which dependency update, but bindgen can still work with which 1.0, I made a bindgen release that allows us to keep using which 1.0:

https://github.com/rust-lang/rust-bindgen/commit/1cd830127489b19a58143c300667d045b447a62d

Flags: needinfo?(emilio)

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=busted&revision=4d220064bcf8acbb47a26c9d622c45d3df67231d&selectedJob=230350963

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=230350963&repo=autoland&lineNumber=22174

Backout link: https://hg.mozilla.org/integration/autoland/rev/d59858e71dee882e1975b947037a77aca05d239b

18:19:13 INFO - [style 0.0.1] cargo:rerun-if-changed=z:/build/build/src/obj-firefox/dist\include\mozilla/Move.h
18:19:13 INFO - Running z:/build/build/src/sccache2/sccache.exe 'z:/build/build/src/rustc/bin/rustc.exe' --crate-name style 'servo\components\style\lib.rs' --color never --crate-type lib --emit=dep-info,link -C opt-level=1 -C panic=abort -C debuginfo=2 -C debug-assertions=on --cfg 'feature="bindgen"' --cfg 'feature="fallible"' --cfg 'feature="gecko"' --cfg 'feature="gecko_debug"' --cfg 'feature="nsstring"' --cfg 'feature="regex"' --cfg 'feature="style_traits"' --cfg 'feature="toml"' --cfg 'feature="use_bindgen"' -C metadata=581b54ff819d3b0b -C extra-filename=-581b54ff819d3b0b --out-dir 'z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps' --target aarch64-pc-windows-msvc -L 'dependency=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps' -L 'dependency=z:/build/build/src/obj-firefox\debug\deps' --extern 'app_units=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libapp_units-ba7c30812f983080.rlib' --extern 'arrayvec=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libarrayvec-5ff12b8467994e4b.rlib' --extern 'atomic_refcell=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libatomic_refcell-c49645a3acd260c4.rlib' --extern 'bitflags=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libbitflags-76cc32b886a8eb42.rlib' --extern 'byteorder=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libbyteorder-31aa52d699306620.rlib' --extern 'cssparser=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libcssparser-77017551c0d7c5cf.rlib' --extern 'derive_more=z:/build/build/src/obj-firefox\debug\deps\derive_more-fe527b91ab5ccea5.dll' --extern 'euclid=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libeuclid-f142830d89548f0a.rlib' --extern 'fallible=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libfallible-e1f81b98437bdb87.rlib' --extern 'fxhash=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libfxhash-c910f9ef68925545.rlib' --extern 'hashglobe=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libhashglobe-351033b494fada89.rlib' --extern 'indexmap=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libindexmap-1fe562ff8901e429.rlib' --extern 'itertools=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libitertools-ddd0ed4ddd1dbe0a.rlib' --extern 'itoa=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libitoa-54cdc17f53b029a0.rlib' --extern 'lazy_static=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\liblazy_static-a096049b29f746e8.rlib' --extern 'log=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\liblog-a8296b7ff27b692d.rlib' --extern 'malloc_size_of=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libmalloc_size_of-41c750a82ccc0cc3.rlib' --extern 'malloc_size_of_derive=z:/build/build/src/obj-firefox\debug\deps\malloc_size_of_derive-065f774ff0cfa8fe.dll' --extern 'matches=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libmatches-788303291339cd74.rlib' --extern 'debug_unreachable=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libdebug_unreachable-18bb755479040dbd.rlib' --extern 'nsstring=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libnsstring-39db8251750e8806.rlib' --extern 'num_derive=z:/build/build/src/obj-firefox\debug\deps\num_derive-40a240f0a43df29c.dll' --extern 'num_integer=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libnum_integer-33e2d2b9ed0883ce.rlib' --extern 'num_traits=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libnum_traits-812ea2f683e9e0df.rlib' --extern 'num_cpus=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libnum_cpus-a87e4c81de158417.rlib' --extern 'ordered_float=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libordered_float-8bbd2b09c39be596.rlib' --extern 'owning_ref=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libowning_ref-f7e2d7445cf7d2ac.rlib' --extern 'parking_lot=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libparking_lot-71551df765828fd8.rlib' --extern 'precomputed_hash=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libprecomputed_hash-6f51913a5008e4aa.rlib' --extern 'rayon=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\librayon-f3ba45a0fac61122.rlib' --extern 'selectors=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libselectors-7ad08e40cab309d7.rlib' --extern 'servo_arc=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libservo_arc-c38cbf0fd06d7603.rlib' --extern 'smallbitvec=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libsmallbitvec-c883a27205aaea53.rlib' --extern 'smallvec=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libsmallvec-a54ea201260e9a57.rlib' --extern 'style_derive=z:/build/build/src/obj-firefox\debug\deps\style_derive-63ea97961ec68a86.dll' --extern 'style_traits=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libstyle_traits-7f72b10fc628969c.rlib' --extern 'thin_slice=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libthin_slice-6674ed01b155a348.rlib' --extern 'time=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libtime-4d7ae3b1ad86f074.rlib' --extern 'uluru=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libuluru-109a08f98890a096.rlib' --extern 'unicode_bidi=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libunicode_bidi-469c7387d3c9e3bb.rlib' --extern 'unicode_segmentation=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libunicode_segmentation-d09f702b12c945b3.rlib' --extern 'void=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libvoid-faa70a7aa07462e9.rlib' -C opt-level=2 -C debuginfo=2 -Dwarnings
18:19:13 INFO - Compiling webrender_bindings v0.1.0 (Z:\build\build\src\gfx\webrender_bindings)
18:19:13 INFO - Running z:/build/build/src/sccache2/sccache.exe 'z:/build/build/src/rustc/bin/rustc.exe' --crate-name webrender_bindings 'gfx\webrender_bindings\src\lib.rs' --color never --crate-type lib --emit=dep-info,link -C opt-level=1 -C panic=abort -C debuginfo=2 -C debug-assertions=on -C metadata=ac597362f37ac9c5 -C extra-filename=-ac597362f37ac9c5 --out-dir 'z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps' --target aarch64-pc-windows-msvc -L 'dependency=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps' -L 'dependency=z:/build/build/src/obj-firefox\debug\deps' --extern 'app_units=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libapp_units-ba7c30812f983080.rlib' --extern 'bincode=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libbincode-3a70fb611a6b1580.rlib' --extern 'dwrote=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libdwrote-16b95f06ae3d8309.rlib' --extern 'euclid=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libeuclid-f142830d89548f0a.rlib' --extern 'fxhash=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libfxhash-c910f9ef68925545.rlib' --extern 'gleam=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libgleam-60431f4903b590ed.rlib' --extern 'log=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\liblog-a8296b7ff27b692d.rlib' --extern 'nsstring=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libnsstring-39db8251750e8806.rlib' --extern 'rayon=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\librayon-f3ba45a0fac61122.rlib' --extern 'thread_profiler=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libthread_profiler-825219183080ab18.rlib' --extern 'uuid=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libuuid-c3d2b5c22dcd73c6.rlib' --extern 'webrender=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libwebrender-8bb305358e8341e2.rlib' -C opt-level=2 -C debuginfo=2 -Dwarnings
18:19:13 INFO - LLVM ERROR: SEH unwind data splitting not yet implemented
18:19:13 ERROR - error: Could not compile style.
18:19:13 INFO - Caused by:
18:19:13 INFO - process didn't exit successfully: z:/build/build/src/sccache2/sccache.exe 'z:/build/build/src/rustc/bin/rustc.exe' --crate-name style 'servo\components\style\lib.rs' --color never --crate-type lib --emit=dep-info,link -C opt-level=1 -C panic=abort -C debuginfo=2 -C debug-assertions=on --cfg 'feature="bindgen"' --cfg 'feature="fallible"' --cfg 'feature="gecko"' --cfg 'feature="gecko_debug"' --cfg 'feature="nsstring"' --cfg 'feature="regex"' --cfg 'feature="style_traits"' --cfg 'feature="toml"' --cfg 'feature="use_bindgen"' -C metadata=581b54ff819d3b0b -C extra-filename=-581b54ff819d3b0b --out-dir 'z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps' --target aarch64-pc-windows-msvc -L 'dependency=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps' -L 'dependency=z:/build/build/src/obj-firefox\debug\deps' --extern 'app_units=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libapp_units-ba7c30812f983080.rlib' --extern 'arrayvec=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libarrayvec-5ff12b8467994e4b.rlib' --extern 'atomic_refcell=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libatomic_refcell-c49645a3acd260c4.rlib' --extern 'bitflags=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libbitflags-76cc32b886a8eb42.rlib' --extern 'byteorder=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libbyteorder-31aa52d699306620.rlib' --extern 'cssparser=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libcssparser-77017551c0d7c5cf.rlib' --extern 'derive_more=z:/build/build/src/obj-firefox\debug\deps\derive_more-fe527b91ab5ccea5.dll' --extern 'euclid=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libeuclid-f142830d89548f0a.rlib' --extern 'fallible=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libfallible-e1f81b98437bdb87.rlib' --extern 'fxhash=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libfxhash-c910f9ef68925545.rlib' --extern 'hashglobe=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libhashglobe-351033b494fada89.rlib' --extern 'indexmap=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libindexmap-1fe562ff8901e429.rlib' --extern 'itertools=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libitertools-ddd0ed4ddd1dbe0a.rlib' --extern 'itoa=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libitoa-54cdc17f53b029a0.rlib' --extern 'lazy_static=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\liblazy_static-a096049b29f746e8.rlib' --extern 'log=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\liblog-a8296b7ff27b692d.rlib' --extern 'malloc_size_of=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libmalloc_size_of-41c750a82ccc0cc3.rlib' --extern 'malloc_size_of_derive=z:/build/build/src/obj-firefox\debug\deps\malloc_size_of_derive-065f774ff0cfa8fe.dll' --extern 'matches=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libmatches-788303291339cd74.rlib' --extern 'debug_unreachable=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libdebug_unreachable-18bb755479040dbd.rlib' --extern 'nsstring=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libnsstring-39db8251750e8806.rlib' --extern 'num_derive=z:/build/build/src/obj-firefox\debug\deps\num_derive-40a240f0a43df29c.dll' --extern 'num_integer=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libnum_integer-33e2d2b9ed0883ce.rlib' --extern 'num_traits=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libnum_traits-812ea2f683e9e0df.rlib' --extern 'num_cpus=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libnum_cpus-a87e4c81de158417.rlib' --extern 'ordered_float=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libordered_float-8bbd2b09c39be596.rlib' --extern 'owning_ref=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libowning_ref-f7e2d7445cf7d2ac.rlib' --extern 'parking_lot=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libparking_lot-71551df765828fd8.rlib' --extern 'precomputed_hash=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libprecomputed_hash-6f51913a5008e4aa.rlib' --extern 'rayon=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\librayon-f3ba45a0fac61122.rlib' --extern 'selectors=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libselectors-7ad08e40cab309d7.rlib' --extern 'servo_arc=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libservo_arc-c38cbf0fd06d7603.rlib' --extern 'smallbitvec=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libsmallbitvec-c883a27205aaea53.rlib' --extern 'smallvec=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libsmallvec-a54ea201260e9a57.rlib' --extern 'style_derive=z:/build/build/src/obj-firefox\debug\deps\style_derive-63ea97961ec68a86.dll' --extern 'style_traits=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libstyle_traits-7f72b10fc628969c.rlib' --extern 'thin_slice=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libthin_slice-6674ed01b155a348.rlib' --extern 'time=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libtime-4d7ae3b1ad86f074.rlib' --extern 'uluru=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libuluru-109a08f98890a096.rlib' --extern 'unicode_bidi=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libunicode_bidi-469c7387d3c9e3bb.rlib' --extern 'unicode_segmentation=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libunicode_segmentation-d09f702b12c945b3.rlib' --extern 'void=z:/build/build/src/obj-firefox\aarch64-pc-windows-msvc\debug\deps\libvoid-faa70a7aa07462e9.rlib' -C opt-level=2 -C debuginfo=2 -Dwarnings (exit code: 101)
18:19:13 INFO - z:/build/build/src/config/makefiles/rust.mk:213: recipe for target 'force-cargo-library-build' failed
18:19:13 INFO - mozmake.EXE[4]: *** [force-cargo-library-build] Error 101
18:19:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/toolkit/library/gtest/rust'
18:19:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/dom/permission'
18:19:13 INFO - dom/permission/Unified_cpp_dom_permission0.obj
18:19:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/dom/permission'
18:19:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/dom/security/featurepolicy'
18:19:13 INFO - z:/build/build/src/sccache2/sccache.exe z:/build/build/src/clang/bin/clang-cl.exe --target=aarch64-windows-msvc -FoUnified_cpp_featurepolicy0.obj -c -Iz:/build/build/src/obj-firefox/dist/stl_wrappers -DDEBUG=1 -DWIN32_LEAN_AND_MEAN -D_WIN32 -DWIN32 -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -DOS_WIN=1 -D_UNICODE -DCHROMIUM_BUILD -DU_STATIC_IMPLEMENTATION -DUNICODE -D_WINDOWS -D_SECURE_ATL -DCOMPILER_MSVC -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -Iz:/build/build/src/dom/security/featurepolicy -Iz:/build/build/src/obj-firefox/dom/security/featurepolicy -Iz:/build/build/src/obj-firefox/ipc/ipdl/_ipdlheaders -Iz:/build/build/src/ipc/chromium/src -Iz:/build/build/src/ipc/glue -Iz:/build/build/src/obj-firefox/dist/include -Iz:/build/build/src/obj-firefox/dist/include/nspr -Iz:/build/build/src/obj-firefox/dist/include/nss -MD -FI z:/build/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -Qunused-arguments -fcrash-diagnostics-dir=z:/build/public/build -TP -nologo -w15038 -wd5026 -wd5027 -Zc:sizedDealloc- -wd4091 -wd4577 -D_HAS_EXCEPTIONS=0 -W3 -Gy -Zc:inline -Gw -wd4251 -wd4244 -wd4267 -wd4800 -wd4595 -wd4065 -Wno-inline-new-delete -Wno-invalid-offsetof -Wno-microsoft-enum-value -Wno-microsoft-include -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -Wno-inconsistent-missing-override -Wno-implicit-exception-spec-mismatch -Wno-unused-local-typedef -Wno-ignored-attributes -Wno-used-but-marked-unused -we4553 -D_SILENCE_TR1_NAMESPACE_DEPRECATION_WARNING -GR- -Z7 -O2 -Xclang -mdisable-fp-elim -WX -Xclang -MP -Xclang -dependency-file -Xclang .deps/Unified_cpp_featurepolicy0.obj.pp -Xclang -MT -Xclang Unified_cpp_featurepolicy0.obj z:/build/build/src/obj-firefox/dom/security/featurepolicy/Unified_cpp_featurepolicy0.cpp
18:19:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/dom/security/featurepolicy'
18:19:13 INFO - z:/build/build/src/config/recurse.mk:74: recipe for target 'toolkit/library/gtest/rust/target' failed
18:19:13 INFO - mozmake.EXE[3]: *** [toolkit/library/gtest/rust/target] Error 2
18:19:13 INFO - mozmake.EXE[3]: *** Waiting for unfinished jobs....

Flags: needinfo?(emilio)
Depends on: 1530448

Can't land this before bug 1530448 is fixed, looks like :(

Flags: needinfo?(emilio)

LLVM fixes landed.

Can you update to a version that contains https://github.com/rust-lang/rust-bindgen/pull/1543 ?

Blocks: 1538060

will do.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.