Closed Bug 1529846 Opened 3 years ago Closed 3 years ago

Unable to download multiple files from website after upgrading to the Firefox 65

Categories

(Firefox :: File Handling, defect, P3)

65 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1542912

People

(Reporter: prtknelge5, Unassigned)

References

(Regression)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.119 Safari/537.36

Steps to reproduce:

I have designed a website, which downloads two files.

  1. test.txt
  2. test.log

Below is the code I Use to download the files

let fileName = 'test.txt';
let Lurl = window.URL.createObjectURL(blobLog);
let Le = document.createElement('a');
Le.setAttribute('href', Lurl);
Le.setAttribute('download', fileName);

let fileName = 'test.log';
let Lurl = window.URL.createObjectURL(blobLog);
let Le = document.createElement('a');
Le.setAttribute('href', Lurl);
Le.setAttribute('download', fileName);

Actual results:

When the Program has run, Only the 'test.log' file gets downloaded.

Expected results:

It should download both the files, test.txt and test.log, one after another.
It works fine before upgrade to version 65.0.1 (64-Bit).

hi, thank you for the report - the problem is looking very similar to the one that's already on file at bug 1528457, so i'll mark it as a duplicate.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Component: Untriaged → HTML: Form Submission
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1528457

Hi,

The Resolution is provided? When the fix can we expect?

Thanks

Severity: normal → major
Status: RESOLVED → UNCONFIRMED
Component: HTML: Form Submission → File Handling
Priority: -- → P3
Product: Core → Firefox
Resolution: DUPLICATE → ---

(In reply to pratik from comment #2)

The Resolution is provided? When the fix can we expect?

the original report wasn't triaged yet, so there is no talk of a fix or how long this is going to take yet.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1528457
Regressed by: 1495363
Duplicate of bug: 1542912

Any update on fix? It's affecting us badly.

You need to log in before you can comment on or make changes to this bug.