windows/aarch64 - disable build/tests/reftest/tests/layout/reftests/bugs/256180-1.html, 256180-2.html, 256180-3.html

RESOLVED FIXED in Firefox 67

Status

defect
--
critical
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: intermittent-bug-filer, Assigned: egao)

Tracking

(Blocks 1 bug, {crash})

unspecified
mozilla67
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 fixed)

Details

(crash signature)

Attachments

(1 attachment)

Reporter

Description

4 months ago
treeherder

#[markdown(off)]
Filed by: egao [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=229891968&repo=try

https://queue.taskcluster.net/v1/task/EuOcrzLaSr66GujjsQKNQw/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/EuOcrzLaSr66GujjsQKNQw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

Raised during reftest-no-accel-e10s-2 on win10/aarch64.

Context:

14:47:20 INFO - REFTEST PROCESS-CRASH | file:///C:/tasks/task_1550846210/build/tests/reftest/tests/layout/reftests/bugs/256180-1.html | application crashed [@ static union core::option::Option<servo_arc::Arc<indexmap::map::IndexMap<style::gecko_string_cache::Atom, servo_arc::Arc<style::custom_properties::VariableValue>, core::hash::BuildHasherDefault<style::selector_map::PrecomputedHasher>>>> style::custom_properties::CustomPropertiesBuilder::build()]
14:47:20 INFO - Crash dump filename: c:\users\testdr~1\appdata\local\temp\tmp1u_n7p.mozrunner\minidumps\a7f7d801-397f-4fa6-93db-54a41cf13002.dmp
14:47:20 INFO - Operating system: Windows NT
14:47:20 INFO - 10.0.17134
14:47:20 INFO - CPU: 0x000c
14:47:20 INFO - 8 CPUs
14:47:20 INFO -
14:47:20 INFO - GPU: UNKNOWN
14:47:20 INFO -
14:47:20 INFO - Crash reason: EXCEPTION_STACK_OVERFLOW
14:47:20 INFO - Crash address: 0x7ffca0b59144
14:47:20 INFO - Assertion: Unknown assertion type 0x00000000
14:47:20 INFO - Process uptime: 6 seconds
14:47:20 INFO -
14:47:20 INFO - Thread 0 (crashed)
14:47:20 INFO - 0 xul.dll!static union core::option::Option<servo_arc::Arc<indexmap::map::IndexMap<style::gecko_string_cache::Atom, servo_arc::Arc<style::custom_properties::VariableValue>, core::hash::BuildHasherDefault<style::selector_map::PrecomputedHasher>>>> style::custom_properties::CustomPropertiesBuilder::build() [custom_properties.rs:e92ff56d2be21676b447c6fbb87b4c4479539bc9 : 610 + 0x10]
14:47:20 INFO -
14:47:20 INFO - Found by: given as instruction pointer in context
14:47:20 INFO - 1 xul.dll!static struct servo_arc::Arc<style::gecko_properties::ComputedValues> style::properties::cascade::cascade_rules<style::gecko::wrapper::GeckoElement>(struct style::gecko::media_queries::Device *, union core::option::Option<style::gecko::pseudo_element::PseudoElement*>, struct style::rule_tree::StrongRuleNode *, struct style::shared_lock::StylesheetGuards *, union core::option::Option<style::gecko_properties::ComputedValues*>, union core::option::Option<style::gecko_properties::ComputedValues*>, union core::option::Option<style::gecko_properties::ComputedValues*>, struct style::font_metrics::FontMetricsProvider*, union style::properties::cascade::CascadeMode, selectors::context::QuirksMode, union core::option::Option<style::rule_cache::RuleCache*>, struct style::rule_cache::RuleCacheConditions *, union core::option::Option<style::gecko::wrapper::GeckoElement>) [cascade.rs:e92ff56d2be21676b447c6fbb87b4c4479539bc9 : 170 + 0x408]
14:47:20 INFO -
14:47:20 INFO - Found by: previous frame's frame pointer
14:47:20 INFO -
14:47:20 INFO - Thread 1
14:47:20 INFO - 0 ntdll.dll!NtRemoveIoCompletion + 0x4
14:47:20 INFO -
14:47:20 INFO - Found by: given as instruction pointer in context
14:47:20 INFO - 1 KERNELBASE.dll + 0x17e9e8
14:47:20 INFO -
14:47:20 INFO - Found by: previous frame's frame pointer

<rest truncated for brevity>

Assignee

Updated

4 months ago
Duplicate of this bug: 1530032
Assignee

Comment 2

4 months ago

I have a sneaking suspicion that this may be due to lack of crashreporter on win10/aarch64.

:svoisen could you point me to the correct person to handle this issue? It does not appear to be failing in windows7/opt-Ru4, so I think this is an windows10-aarch64 issue.

Flags: needinfo?(svoisen)
Assignee

Updated

4 months ago
Summary: win10/aarch64 - REFTEST PROCESS-CRASH | file:///C:/tasks/task_1550846210/build/tests/reftest/tests/layout/reftests/bugs/256180-1.html | application crashed → windows/aarch64 - REFTEST PROCESS-CRASH | file:///C:/tasks/task_1550846210/build/tests/reftest/tests/layout/reftests/bugs/256180-1.html | application crashed

@egao hsivonen authored the test and fixed the related bug, so maybe he might know why this is crashing on aarch64?

Flags: needinfo?(svoisen) → needinfo?(hsivonen)
Assignee

Updated

4 months ago
Summary: windows/aarch64 - REFTEST PROCESS-CRASH | file:///C:/tasks/task_1550846210/build/tests/reftest/tests/layout/reftests/bugs/256180-1.html | application crashed → windows/aarch64 - REFTEST PROCESS-CRASH | build/tests/reftest/tests/layout/reftests/bugs/256180-1.html | application crashed

The test relies on Firefox having a non-default runtime stack size on Windows. https://searchfox.org/mozilla-central/rev/dbddac86aadf1d4871fb350bbe66db43728a9f81/config/config.mk#293 needs to be adjusted to set the stack size to 8 MB on aarch64 Windows, too.

Flags: needinfo?(hsivonen)

Moving over to build system, since this is build config problem.

Component: Layout → General
Priority: P5 → --
Product: Core → Firefox Build System
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Assignee

Updated

3 months ago
Summary: windows/aarch64 - REFTEST PROCESS-CRASH | build/tests/reftest/tests/layout/reftests/bugs/256180-1.html | application crashed → windows/aarch64 - REFTEST PROCESS-CRASH | build/tests/reftest/tests/layout/reftests/bugs/256180-1.html, 256180-2.html, 256180-3.html | application crashed
Assignee

Comment 9

3 months ago

Bug is being disabled with attached patch for a greener run on windows10-aarch64 platform.

Comment 10

3 months ago
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/26192d9f0bca
disable build/tests/reftest/tests/layout/reftests/bugs/256180-1.html, 256180-2.html, 256180-3.html r=jmaher

Comment 11

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Is there another bug on file for actually fixing this as described in comment 4?

Flags: needinfo?(egao)
Assignee

Comment 13

3 months ago

(In reply to Henri Sivonen (:hsivonen) from comment #12)

Is there another bug on file for actually fixing this as described in comment 4?

I used this bug to disable the tests for the time being, I could file a new bug to implement the fix if reusing this bug isn't preferable.

Flags: needinfo?(egao) → needinfo?(hsivonen)

(In reply to Edwin Gao (:egao) from comment #13)

(In reply to Henri Sivonen (:hsivonen) from comment #12)

Is there another bug on file for actually fixing this as described in comment 4?

I used this bug to disable the tests for the time being, I could file a new bug to implement the fix if reusing this bug isn't preferable.

Considering that this has been marked FIXED, it would be clearer to file a separate Bugzilla bug for fixing the actual build system bug and re-enabling the test.

Flags: needinfo?(hsivonen)
Assignee

Updated

3 months ago
Blocks: 1536575
Assignee

Updated

3 months ago
Summary: windows/aarch64 - REFTEST PROCESS-CRASH | build/tests/reftest/tests/layout/reftests/bugs/256180-1.html, 256180-2.html, 256180-3.html | application crashed → windows/aarch64 - disable build/tests/reftest/tests/layout/reftests/bugs/256180-1.html, 256180-2.html, 256180-3.html
You need to log in before you can comment on or make changes to this bug.