The Reload button has the icon misplaced in Customize mode

VERIFIED FIXED in Firefox 66

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
4 months ago

People

(Reporter: csasca, Assigned: bgrins)

Tracking

({regression})

65 Branch
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 wontfix, firefox66+ verified, firefox67 verified)

Details

Attachments

(2 attachments)

Reporter

Description

4 months ago
Posted image Reload misplaced.png

Affected versions

  • Firefox 65.0.1
  • Firefox Beta 66.0b9
  • Firefox DevEdition 66.0b10
  • Firefox Nightly 67.0a1 (2019-02-25)

Affected platforms

  • Windows 7 (x64)
  • Windows 10 (x64)
  • Ubuntu 18.04 (x64)
  • macOS 10.14

Steps to reproduce

  1. Start Firefox
  2. Enter the Customize page
  3. Drag and drop the reload button in the list

Expected result

  • There are no glitches with the button.

Actual result

  • The reload icon is misplaced.

Regression range

  • I will get back with a regression asap.
Reporter

Updated

4 months ago
Has Regression Range: --- → no
  • Last good revision: efa49008bfc788e3354d6150eab71a7f105e3102
  • First bad revision: 8f7476054232c929476c1a5112bb855f6ba7612f

Pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=efa49008bfc788e3354d6150eab71a7f105e3102&tochange=8f7476054232c929476c1a5112bb855f6ba7612f

It looks like 1507875 is causing the regression.

Has Regression Range: no → yes

Comment 2

4 months ago

[Tracking Requested - why for this release]:
user-visible regression in a recent release.

Brian, can you take a look, please? :-)

(I expect the stop/reload button is special because it's a toolbaritem instead of a toolbarbutton, and contains only 1 visible item at a time, and because it's in the toolbar by default we didn't notice it -- but it'd be good to check that the bookmarks toolbar items look OK still.)

Blocks: 1507875
Flags: needinfo?(bgrinstead)
Priority: -- → P1
Assignee

Updated

4 months ago
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)

Comment 4

4 months ago
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c9a0cb62184d
Center align the reload button in customize mode r=Gijs

Comment 5

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Has STR: --- → yes

Gijs do you want to request beta uplift since Brian is out this week?

Flags: needinfo?(gijskruitbosch+bugs)
Version: Trunk → 65 Branch

I have reproduced this bug with Nightly 67.0a1 (2019-02-25) on Windows 7, 64 Bit. This bug's fix is verified with latest Nightly!

Build ID : 20190304093752
User Agent : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

QA Whiteboard: [bugday-20190227]

Comment 8

4 months ago

Comment on attachment 9046961 [details]
Bug 1530288 - Center align the reload button in customize mode

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1507875
  • User impact if declined: odd-looking reload button when moved to palette
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Check styling of reload/stop button in customize mode in toolbar, palette and overflow panel
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): CSS-only change

(Note that there are extensive tests for customize mode, but this issue is a styling one so automated tests don't catch it.)

  • String changes made/needed: no
Flags: needinfo?(gijskruitbosch+bugs)
Attachment #9046961 - Flags: approval-mozilla-beta?

Comment on attachment 9046961 [details]
Bug 1530288 - Center align the reload button in customize mode

CSS tweak for customize menu. OK for beta 14 uplift.

Attachment #9046961 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [bugday-20190227] → [bugday-20190227][qa-triaged]

I managed to reproduce the issue on an older version of Nightly (2019-02-25) on Windows 10 x64.
I retested everything using latest Nightly 67.0a1 and beta 66.0b14 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.14, but the bug is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.