Closed Bug 1530423 Opened 9 months ago Closed 8 months ago

Debugger does not pause at breakpoints except for the 1st window (round 2)

Categories

(DevTools :: Debugger, defect, P2)

66 Branch
defect

Tracking

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 fixed, firefox67 fixed)

RESOLVED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed
firefox67 --- fixed

People

(Reporter: Oriol, Assigned: ravefalcon92)

References

Details

(Keywords: regression)

Attachments

(2 files)

Bug 1528654 wasn't completely fixed:

  1. Start with a clean profile
  2. Press Ctrl+Shift+I to open devtools
  3. Press F1 to open devtools preferences
  4. Check "Enable browser chrome and add-on debugging toolboxes"
  5. Check "Enable remote debugging"
  6. Press Ctrl+Alt+Shift+I to open Browser Toolbox
  7. In the Browser Toolbox, switch to the debugger panel
  8. Press Ctrl+P to find file /content/browser.js, open it
  9. Press Ctrl+F to search gBrowser.stop(), add a breakpoint in that line.
  10. In the Firefox window you should have two tabs (first run and privacy notice)
  11. Right-click one of them, choose "Move Tab" and "Move to New Window".
  12. The debugger pauses as expected, resume it.
  13. The tab will move into a new window.
  14. Open a 2nd tab in this new window.
  15. Right-click it and move it into a new window.

Expected: the debugger pauses again.
Actual: the debugger doesn't pause.

Flags: needinfo?(lsmyth)

I tracked this down and see what's going on, but it actually looks like this is probably an existing issue that was not caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1518661.

It's the same root cause as the other bug you filed. We're making an incorrect assumption about the relationship between scripts and sources, but it is in code that I didn't change as part of the breakpoint changes.

Version: 67 Branch → 66 Branch

Interesting, I'll revisit when I get a chance. If that did introduce it, it's likely entirely by chance, since I don't think there are any explicit issues with that patch on its own, probably just the way it interacts with other existing code.

Priority: -- → P2
Attachment #9048958 - Attachment description: Bug 1530423 - Pause on breakpoint for _all_ evaluations of a Debugger.Source → Bug 1530423 - Ensure breakpoints are added to newly-cloned JSScripts for existing sources. r=loganfsmyth
Pushed by lsmyth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/173e4de60b4a
Ensure breakpoints are added to newly-cloned JSScripts for existing sources. r=loganfsmyth
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Is this safe to uplift?

Assignee: nobody → ravefalcon92
Attached patch bug1530423.patchSplinter Review

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1513095
  • User impact if declined: Users of the browser toolbox JS debugger may have certain breakpoints ignored entirely, making debugging more difficult.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This change is not risky because this just removes a special-case for previously-seen objects and makes things consistent across more cases.
  • String changes made/needed:
Flags: needinfo?(lsmyth)
Attachment #9049667 - Flags: approval-mozilla-beta?

This uplift patch also includes additional changes not in the original patch here, but they are only applicable changes for unit tests, so no concern there.

Comment on attachment 9049667 [details] [diff] [review]
bug1530423.patch

Fix for regression in 66, adds new tests, let's take it for the RC.
Attachment #9049667 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.