Closed Bug 1530683 Opened 2 years ago Closed 2 years ago

2019-02-26 build lost my session

Categories

(Firefox :: Session Restore, defect)

Desktop
All
defect
Not set
major

Tracking

()

RESOLVED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 blocking fixed

People

(Reporter: overholt, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

I clicked "restart to update", Firefox didn't restart, and when I restarted it manually my session was gone. History appears accurate but my pinned and non-pinned tabs are gone.

Running Ubuntu 18.10 here. After I clicked "restart to update", my FF restarted and crashed immediately. When I restarted it manually my session was gone too.

OS: Windows 10 → All

Just applied the update and had the same bug. Loading about:sessionrestore manually allowed me to restore my previous session.

pushlog between the last 2 builds:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=49b2a4c8be01&tochange=110ea2a7c3d4

One session restore bug in that range:
https://bugzilla.mozilla.org/show_bug.cgi?id=1442694

Doug, fyi this patch may have caused this regression.

One oddity on restart is that the session was empty with one pinned blank tab, I believe that Julien also had the same blank pinned tab.

Flags: needinfo?(dothayer)

(FWIW I don't think I had one blank pinned tab)

I had the same problem with this morning's build https://hg.mozilla.org/mozilla-central/rev/110ea2a7c3d4f34b5079c195f7ea57966748e6da . This morning I woke up, did the update to last night's build that I hadn't done yet, went away for 25-30 minutes, did this morning's update (like the previous, via the green notification on the hamburger menu), and the second update ended up with a weird partial-restore of the session (there were the right number of windows, not enough tabs in them, and all the tabs were blank). I quit Firefox, restored the sessionstore from the first update I did this morning (to last night's build) (cd <profile-dir>/sessionstore-backups/; cp -p upgrade.jsonlz4-20190225215823 ../sessionstore.jsonlz4) and then it restored correctly.

(I had multiple blank pinned tabs, I think... but not as many pinned tabs as I should have had.)

Uh oh, looking into this.

For now nightly updates are pinned to the 20190225215823 build.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(dothayer)
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Duplicate of this bug: 1530673

Is there a way for this to be caught in automated testing?

I am adding tests which recreate this and similar failures before implementing the fix. More generally, it seems that there just wasn't as much breadth in pinned tabs testing as would have been necessary to catch this.

(In reply to Julien Cristau [:jcristau] from comment #8)

For now nightly updates are pinned to the 20190225215823 build.

Respins with the backout are available. I've removed the pinning rule.

Severity: normal → major

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?
Root Cause: ? → Coding: Logical Error
You need to log in before you can comment on or make changes to this bug.