Bustages on "LauncherRegistryInfo" when Gecko 67 merges to beta on 2019-03-11

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
6 months ago
6 months ago

People

(Reporter: NarcisB, Assigned: aklotz)

Tracking

unspecified
Firefox 67
Unspecified
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67+ fixed)

Details

Attachments

(1 attachment)

[Tracking Requested - why for this release]:

Central as Beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=5b9147663e9d846d6d52c5294798c90343d97b53&selectedJob=230538132

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=230538132&repo=try&lineNumber=30034

Log snippet:

15:21:17 INFO - z:/build/build/src/browser/app/winlauncher/ErrorHandler.cpp(685,12): error: no type named 'LauncherRegistryInfo' in namespace 'mozilla'
15:21:17 INFO - mozilla::LauncherRegistryInfo regInfo;
15:21:17 INFO - ~~~~~~~~~^
15:21:17 INFO - z:/build/build/src/browser/app/winlauncher/ErrorHandler.cpp(686,36): error: no member named 'LauncherRegistryInfo' in namespace 'mozilla'
15:21:17 INFO - mozilla::LauncherResult<mozilla::LauncherRegistryInfo::EnabledState>
15:21:17 INFO - ~~~~~~~~~^
15:21:17 INFO - z:/build/build/src/browser/app/winlauncher/ErrorHandler.cpp(687,7): error: C++ requires a type specifier for all declarations
15:21:17 INFO - launcherEnabled = regInfo.IsEnabled();
15:21:17 INFO - ^
15:21:17 INFO - z:/build/build/src/browser/app/winlauncher/ErrorHandler.cpp(690,20): error: no member named 'LauncherRegistryInfo' in namespace 'mozilla'
15:21:17 INFO - mozilla::LauncherRegistryInfo::EnabledState::ForceDisabled) {
15:21:17 INFO - ~~~~~~~~~^
15:21:17 INFO - 4 errors generated.
15:21:17 INFO - z:/build/build/src/config/rules.mk:805: recipe for target 'Unified_cpp_app_winlauncher0.obj' failed
15:21:17 INFO - mozmake.EXE[4]: *** [Unified_cpp_app_winlauncher0.obj] Error 1
15:21:17 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/browser/app/winlauncher'
15:21:17 INFO - z:/build/build/src/config/recurse.mk:74: recipe for target 'browser/app/winlauncher/target' failed
15:21:17 INFO - mozmake.EXE[3]: *** [browser/app/winlauncher/target] Error 2
15:21:17 INFO - mozmake.EXE[3]: *** Waiting for unfinished jobs....

:aklotz , this is caused by https://hg.mozilla.org/mozilla-central/rev/7f034553129d.
Could you please take a look?

Flags: needinfo?(aklotz)
Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Flags: needinfo?(aklotz)
OS: Unspecified → Windows
Priority: P1 → --
Priority: -- → P1
Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5be3bd53aaad
Add a missing ifdef MOZ_LAUNCHER_PROCESS block; r=mhowell
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.