Assertion failure: mStart <= mEnd (Invalid Interval), at src/dom/media/Intervals.h:48

RESOLVED FIXED in Firefox 67

Status

()

defect
P2
normal
Rank:
15
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: tsmith, Assigned: jya)

Tracking

(Blocks 2 bugs, {assertion, crash, testcase})

unspecified
mozilla67
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox-esr60 wontfix, firefox65 wontfix, firefox66 wontfix, firefox67 fixed)

Details

(crash signature)

Attachments

(2 attachments)

Reporter

Description

4 months ago
Posted video testcase.webm

Assertion failure: mStart <= mEnd (Invalid Interval), at src/dom/media/Intervals.h:48

#0 IsWaitingForKey src/dom/media/MediaFormatReader.h:408:14
#1 mozilla::MediaFormatReader::Update(mozilla::TrackInfo::TrackType) src/dom/media/MediaFormatReader.cpp:2443
#2 applyImpl<mozilla::MediaFormatReader, void (mozilla::MediaFormatReader::*)(mozilla::TrackInfo::TrackType), StoreCopyPassByConstLRef<mozilla::TrackInfo::TrackType> , 0> src/obj-firefox/dist/include/nsThreadUtils.h:1119:12
#3 apply<mozilla::MediaFormatReader, void (mozilla::MediaFormatReader::*)(mozilla::TrackInfo::TrackType)> src/obj-firefox/dist/include/nsThreadUtils.h:1125
#4 mozilla::detail::RunnableMethodImpl<mozilla::MediaFormatReader*, void (mozilla::MediaFormatReader::*)(mozilla::TrackInfo::TrackType), true, (mozilla::RunnableKind)0, mozilla::TrackInfo::TrackType>::Run() src/obj-firefox/dist/include/nsThreadUtils.h:1171
#5 mozilla::AutoTaskDispatcher::TaskGroupRunnable::Run() src/obj-firefox/dist/include/mozilla/TaskDispatcher.h:197:35
#6 mozilla::TaskQueue::Runner::Run() src/xpcom/threads/TaskQueue.cpp:199:12
#7 nsThreadPool::Run() src/xpcom/threads/nsThreadPool.cpp:241:14
#8 non-virtual thunk to nsThreadPool::Run() src/xpcom/threads/nsThreadPool.cpp
#9 nsThread::ProcessNextEvent(bool, bool*) src/xpcom/threads/nsThread.cpp:1162:14
#10 NS_ProcessNextEvent(nsIThread*, bool) src/xpcom/threads/nsThreadUtils.cpp:474:10
#11 mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) src/ipc/glue/MessagePump.cpp:303:20
#12 RunInternal src/ipc/chromium/src/base/message_loop.cc:315:10
#13 RunHandler src/ipc/chromium/src/base/message_loop.cc:308
#14 MessageLoop::Run() src/ipc/chromium/src/base/message_loop.cc:290
#15 nsThread::ThreadFunc(void*) src/xpcom/threads/nsThread.cpp:449:11
#16 _pt_root src/nsprpub/pr/src/pthreads/ptthread.c:201:5
Flags: in-testsuite?
Reporter

Updated

4 months ago
See Also: → 1530897

Updated

4 months ago
Rank: 15
Priority: -- → P2
Assignee

Updated

4 months ago
Duplicate of this bug: 1531730
Assignee

Updated

4 months ago
Crash Signature: [@ mozilla::MediaFormatReader::Update]
Assignee

Comment 2

4 months ago

WebM specify that timestamp must be motonically increasing. Unfortunately, this is not always the case.

Assignee

Updated

4 months ago
Assignee: nobody → jyavenard

Comment 3

4 months ago
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1712a35cd239
Set frame duration to 0 when out of order frames are seen. r=bryce

Comment 4

4 months ago
bugherder
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Can we land the testcase for this as a crashtest?

Flags: needinfo?(jyavenard)
Assignee

Comment 6

4 months ago

will do so in bug 1531991

Flags: needinfo?(jyavenard)
Assignee

Updated

4 months ago
Blocks: 1531991
You need to log in before you can comment on or make changes to this bug.