[Search Quantumbar] One-click search in new tab function doesn't open a new tab

RESOLVED FIXED in Firefox 67

Status

()

defect
P3
normal
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: laszlo.bialis, Assigned: standard8)

Tracking

(Blocks 2 bugs)

Trunk
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 unaffected)

Details

(Whiteboard: [fxsearch])

Attachments

(3 attachments)

Reporter

Description

3 months ago

Affected versions

  • Nightly 67.0a1

Affected platforms

  • Win10 x64, macOS 10.14, Ubuntu 16.04

Steps to reproduce

  1. Launch Firefox
  2. Make sure "browser.urlbar.quantumbar" is set to "true" in about:config
  3. Restart the browser
  4. Use the same profile as before and type something in the URL bar
  5. Right click on a one-click search button
  6. From the context menu select the Search in New Tab item.

Expected result

  • Search should be performed in a new tab with the selected one-click search engine but with the focus remaining on the tab where the search has been started.

Actual result

  • Search is performed in a the same tab from where the text was typed in the URL bar.

Additional notes

  • The issue affects Quantumbar only, in Awesomebar the Search in New Tab works ok.
Priority: -- → P3
Whiteboard: [fxsearch]
Reporter

Updated

3 months ago
No longer blocks: quantumbar-release
Priority: P3 → --
Whiteboard: [fxsearch]

We can't mark 67 as affected because we're not releasing the QB in 67.

Priority: -- → P3
Whiteboard: [fxsearch]
Assignee: nobody → standard8
Status: NEW → ASSIGNED

I just noticed, this also always searches using the default search engine rather than the one you're right-clicking on.

This seems to make more sense as it is currently only handling the search service.

So bug 1525101 has actually just landed a fix for this - because we no longer have any more anonymous elements following the search popup move away from URLs.

However, I'll still be landing all of this, since this will at least add a test to make sure we don't break it in future.

Depends on: 1525101

(In reply to Mark Banner (:standard8) from comment #6)

So bug 1525101 has actually just landed a fix for this - because we no longer have any more anonymous elements following the search popup move away from URLs.

However, I'll still be landing all of this, since this will at least add a test to make sure we don't break it in future.

Err, actually it broke the context menu for the existing address bar, which probably means my change actually broke the search popup.

I'll figure out a fix that works for everywhere.

Attachment #9048934 - Attachment description: Bug 1530961 - Fix the 'search in new tab' option for search one-offs in QuantumBar. r?adw → Bug 1530961 - Fix the right-click 'search in new tab' option for search one-offs to work in all situations. r?adw

Comment 8

3 months ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e01745bb65d
Move SearchTestUtils.jsm from browser to toolkit. r=adw
https://hg.mozilla.org/integration/autoland/rev/a5c70252fc38
Move waitForSearchNotification from head_search.js to SearchTestUtils.jsm. r=adw
https://hg.mozilla.org/integration/autoland/rev/3815b3ac1823
Fix the right-click 'search in new tab' option for search one-offs to work in all situations. r=adw

Comment 9

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.