Video hardware decoder no longer work with e10s off

RESOLVED FIXED in Firefox 67

Status

()

defect
P2
normal
Rank:
15
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: jya, Assigned: jya)

Tracking

(Blocks 1 bug, {regression})

unspecified
mozilla67
x86
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66+ wontfix, firefox67 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

3 months ago

With e10s off, HW decoding no longer works.

This is due to https://searchfox.org/mozilla-central/source/gfx/thebes/gfxWindowsPlatform.cpp#454
bool gfxWindowsPlatform::CanUseHardwareVideoDecoding() always return false as dm->TextureSharingWorks() always return false, and it returns false because DeviceManagerDx::TextureSharingWorks has DeviceManagerDx::mDeviceStatus not set at the time the test is done.

This was regressed in bug 1513308.

The ability to work with the hardware decoders functional while e10s is off is essential to my workflow as developing and debugging the various HW decoder over various process and IPC communication is much more complex.

Updated

3 months ago
Rank: 15
Priority: -- → P2

Comment 2

3 months ago
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f9e25c03e77a
Initialize D3D devices immediately when e10s is not active. r=mattwoodrow
Assignee

Updated

3 months ago
Blocks: 1531207
Assignee

Updated

3 months ago
Assignee: nobody → jyavenard

Comment 3

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

I'm guessing this is something we want to backport to Beta to avoid shipping the regression? Please nominate if so :)

Flags: needinfo?(jyavenard)

Updated

3 months ago

If I recall correctly from talking for jya 66 is not affected by this, because on 66 two other bugs are canceling each other out so that we don't have the same problem.

@jya is this right, or do we need to nominate this for uplift?

Assignee

Comment 6

2 months ago

If I recall correctly from talking for jya 66 is not affected by this, because on 66 two other bugs are canceling each other out so that we don't have the same problem.

@jya is this right, or do we need to nominate this for uplift?

this was in reference to another bug that got slightly better.

However HW decoding would still be disabled on 66 as a consequence.

It's not that urgent to uplift to 66 as I believe everyone should be with a GPU decoder enabled and e10s on these days.

Flags: needinfo?(jyavenard)
QA Whiteboard: [qa-67b-p2]
You need to log in before you can comment on or make changes to this bug.