RTCPeerConnection.currentRemote/LocalDescription can have the wrong type

RESOLVED FIXED in Firefox 67

Status

()

defect
P2
normal
Rank:
14
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: bwc, Assigned: bwc)

Tracking

(Blocks 1 bug)

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

https://jsfiddle.net/jevrh87z/

The problem is that the type for currentRemoteDescription is set in setRemoteDescription, but it should only be set when negotiation finishes, because currentRemoteDescription is the currently negotiated remote description.

https://searchfox.org/mozilla-central/rev/2a6f3dde00801374d3b2a704232de54a132af389/dom/media/PeerConnection.jsm#1014

There is a similar problem with currentLocalDescription.

https://searchfox.org/mozilla-central/rev/2a6f3dde00801374d3b2a704232de54a132af389/dom/media/PeerConnection.jsm#945

Rank: 16 → 14
Assignee: nobody → docfaraday

Depends on D21557

Depends on D22207

Blocks: 1533020

Ping for review on part 3.

Flags: needinfo?(jib)
Flags: needinfo?(jib)
Attachment #9048697 - Attachment description: Bug 1531156 - Part 3: Some code simplification that part 1 lets us do. → Bug 1531156 - Part 2: Some code simplification that part 1 lets us do.
Attachment #9048696 - Attachment is obsolete: true
Attachment #9048696 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.