Closed Bug 1531604 Opened 2 years ago Closed 2 years ago

Fix "position" field on Pocket story clicks in Discovery Stream variants

Categories

(Firefox :: New Tab Page, defect, P1)

66 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 67
Iteration:
67.3 - Feb 25 - Mar 10
Tracking Status
firefox66 + verified
firefox67 --- verified

People

(Reporter: kirill, Assigned: thecount, Mentored)

References

Details

(Keywords: github-merged)

Attachments

(3 files)

In non-control variants of the pref-flip-study-activity-stream-pkt-newtab-beta66complexandperformance2-1529327 shield study, we are not recording the position of click events and impression events consistently.

This makes it impossible to calculate CTR and # of clicks for a given position in the new tab, which hinders Pocket's effort to add additional sponsored content to the Firefox New Tab page.

Impressions are currently assigned position in the following manner. Let us use the example of 2 rows of 4 Pocket stories:
0-1-2-3
4-5-6-7

Clicks are currently assigned position in the follow manner. Let us again use the same example of 2 rows of 4 Pocket stories:
0-1-2-3
0-1-2-3

Can you please change the "position" parameter on clicks to be consistent with impressions before 66 release?

[Tracking Requested - why for this release]: Correct numbers needed for experiment

Blocks: 1512725
Duplicate of this bug: 1531610

Can you verify this once it lands in nightly? Thanks!

Flags: qe-verify+
Flags: needinfo?(kirill)
Blocks: 1532321
Assignee: nobody → sdowne
Iteration: --- → 67.3 - Feb 25 - Mar 10
Priority: -- → P1
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Comment on attachment 9048636 [details]
Bug 1531604 - Fixing impression pos

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1522832
  • User impact if declined: Experiment data issues not valuable.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: We need to verify this on the server, that the metrics position are coming in as expected in beta/nightly.
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): Feature is preffed off, should be verified in nightly shortly.
  • String changes made/needed: none
Attachment #9048636 - Flags: approval-mozilla-beta?

Verified! Position is coming in correctly for impressions and clicks in latest Nightly build.

Flags: needinfo?(kirill)

Comment on attachment 9048636 [details]
Bug 1531604 - Fixing impression pos

Uplift all the things!

Attachment #9048636 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: RESOLVED → VERIFIED

Based on the above comments this was verified in Nightly (Fx67) and waiting for the fix to hit Beta (Fx66). Changing the flags accordingly.

QA Whiteboard: [qa-triaged]

(In reply to Kirill Demtchouk from comment #9)

Verified! Position is coming in correctly for impressions and clicks in latest Nightly build.

Could you do the same verification for Beta if you don't mind?

Flags: needinfo?(kirill)

Verified that this is working as expected in latest Beta!

Flags: needinfo?(kirill)
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.