Can't attach files from directories other than current

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Eric Pollmann, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

19 years ago
Attaching files from a directory other than current posts a file of zero length.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Comment 1

19 years ago
After careful consideration, I've decided that I probably won't get this bug in
for M12.  Currently I have nearly 50 bugs scheduled for M13, so there is a
possibility that this bug may need to be moved out farther still.

Comment 2

19 years ago
QA Contact update.
Target Milestone: M13 → M15
Moving to M15 as this will only be hit by users attaching files from the
non-current directory. Usually users will use the Browse... button and select
the file using the File Open dialog, making its directory current and avoiding
this. (I think. ;-> )

Comment 4

19 years ago
Eric, how are you attaching the files from directories other than the current
one?  Are you using a convention like ../one_up_from_current/this_file.foo in
the File Name field?
(Assignee)

Comment 5

19 years ago
I think the problem is that the file picker dialog just returns the filename and
not a fully qualified path.  Either a relative ../ style path or an absolute
/u/user/public/file/... style path would work.
(Assignee)

Comment 6

19 years ago
This works for me in today's build.  Marking WORKSFORME.  Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 7

18 years ago
Updating QA contact.
QA Contact: ckritzer → vladimire

Comment 8

18 years ago
Created attachment 15657 [details]
Dont open, test test test test test

Comment 9

18 years ago
Created attachment 15660 [details]
Another test test test test DONT OPEN

Comment 10

18 years ago
Verifying on
 -Windows 98 build 2000-09-26-08-M18
 -Linux RedHat6.2 build 2000-09-27-08-M18
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.