Closed Bug 15317 Opened 21 years ago Closed 20 years ago

Can't attach files from directories other than current

Categories

(Core :: DOM: Core & HTML, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: pollmann, Assigned: pollmann)

References

()

Details

Attachments

(2 files)

Attaching files from a directory other than current posts a file of zero length.
Status: NEW → ASSIGNED
Target Milestone: M12
After careful consideration, I've decided that I probably won't get this bug in
for M12.  Currently I have nearly 50 bugs scheduled for M13, so there is a
possibility that this bug may need to be moved out farther still.
QA Contact update.
Target Milestone: M13 → M15
Moving to M15 as this will only be hit by users attaching files from the
non-current directory. Usually users will use the Browse... button and select
the file using the File Open dialog, making its directory current and avoiding
this. (I think. ;-> )
Eric, how are you attaching the files from directories other than the current
one?  Are you using a convention like ../one_up_from_current/this_file.foo in
the File Name field?
I think the problem is that the file picker dialog just returns the filename and
not a fully qualified path.  Either a relative ../ style path or an absolute
/u/user/public/file/... style path would work.
This works for me in today's build.  Marking WORKSFORME.  Thanks!
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Updating QA contact.
QA Contact: ckritzer → vladimire
Verifying on
 -Windows 98 build 2000-09-26-08-M18
 -Linux RedHat6.2 build 2000-09-27-08-M18
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.