Closed Bug 1531900 Opened 2 years ago Closed 1 year ago

RTCPeerConnection-createDataChannel.html wpt has a faulty test: "createDataChannel with provided parameters should initialize attributes to provided values"

Categories

(Core :: WebRTC: Signaling, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1610579

People

(Reporter: bwc, Unassigned)

References

(Blocks 1 open bug)

Details

This test explicitly passes null as an initializer for an integer member of a dictionary. JS says that this causes that member to be initted to 0, not null, as far as I can tell.

Rank: 25
Priority: -- → P3

Makes sense, the test is old. These used to be nullable.

Blocks: 1533020
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1610579
You need to log in before you can comment on or make changes to this bug.