Choppy scrolling on partner site (Askmen.com)

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Susie Wyshak, Assigned: dcone (gone))

Tracking

({testcase, topembed})

Trunk
mozilla1.1beta
x86
Windows 2000
testcase, topembed

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Using 6/20 trunk on Win2K.

Drag the scroll bar up and down on this page - which I had done in a real
scenario in scanning this page (for a friend ;-)

http://www.askmen.com/dating/doclove/59_relationship_expert.html
(Reporter)

Updated

16 years ago
Whiteboard: topembed
Need a reduced test case.
Keywords: topembed
Whiteboard: topembed → [TESTCASE]
WFM: Using 200-06-21 1.0 branch build of Mozilla on 750Mhz AMD WinXP sytem. It
scrolls smoothly. Not choppy at all.

Comment 3

16 years ago
Also works fine on 2002062408 trunk build. The scrolling is smooth.
(Reporter)

Comment 4

16 years ago
FYI I noticed the choppiness when I dragged really "hard" as I wanted to get to
the bottom of the page quickly. (I've never been a "Page Down" person.) 

I noticed if you scroll at a reading speed it's fine.
I will download one of those newer builds though to doublecheck.
(Reporter)

Comment 5

16 years ago
This is another site that repaints in "chunks" when you quickly scroll back to
the top.
http://www.mmoh.com/

(fyi I use 600x800 which is why I scroll so much) :-)
WFM: http://www.mmoh.com/ using 2002070304 trunk build on WinXP. Scrolls smoothly.

Reassigning to dcone. Maybe he can reproduce.
Assignee: kmcclusk → dcone
(Reporter)

Comment 7

16 years ago
Works fine for mgalli on Win98.
Could it only be a Win2K problem?

I have noticed frequent choppy scrolling sites, using Windows 2000.
(Gecko/20020702 branch)
Example: http://www.sfgate.com/traffic/

(Chrisd if your team could look into a reduced test case that might help. Thanks.)

Comment 8

16 years ago
I can reproduce this problem if drag the scroll bar up/down quickly. Tested
under Windows ME (2002-07-09-08 1.0.0) and (2002-07-02-04 trunk). All of the
sites listed have very wide background images in the BODY.
http://www.askmen.com/ (1300 x 1) , http://www.mmoh.com (2000 x 2),  and
http://www.sfgate.com/ (1500 x 1).

Comment 9

16 years ago
Created attachment 90651 [details]
reduced test case

Comment 10

16 years ago
Created attachment 90697 [details]
Better reduced test case from http://www.mmoh.com

Page contains a wide background image. I can reproduce choppy issue when I drag
the scroll bar up/down quickly.

Updated

16 years ago
Keywords: testcase
(Assignee)

Comment 11

16 years ago
I just tested 6.2 (very choppy) and the trunk (very smooth).  I just put in a
fix that makes rendering animated GIFs faster.. can you re-test this now (trunk
build) see if you get the same results as I do.  I think this may be fixed from
a checkin I did yesterday.
(Reporter)

Comment 12

16 years ago
It's fixed! Very nice :-) 

Tested on Win2K 2002-07-10-04 commercial trunk
Keywords: nsbeta1
(Reporter)

Comment 13

16 years ago
Did this fix have something to do with wide background images also, or was the
problem just due to animated gifs?
(Assignee)

Comment 14

16 years ago
A problem with wide images was fixed a few weeks ago.. this fix was for animated
GIFS.  I am marking this as fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 15

16 years ago
don - this was resolved fixed, but i do not see a patch attached to this bug.
was this fixed as part of another checkin, or am i missing somehting here? if
yes, pls change resolution to WFM, and referrence the other checkin. thanks!
Keywords: nsbeta1 → nsbeta1+
Target Milestone: --- → mozilla1.1beta
(Assignee)

Comment 16

16 years ago
143830 fixed this bug.

Comment 17

16 years ago
Verified on the 2002-07-11-08 trunk.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

16 years ago
This site is still really choppy on the 7/23 branch build:
http://www.sfgate.com/traffic/
(Reporter)

Comment 19

16 years ago
Could there be a regression? The Ask Men site is choppy again also...not like
after we verified it fixed. Reopening...
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 20

16 years ago
This is a trunk fix.. this is not on the branch.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

16 years ago
I am not clear from the comments if this bug or bug 143830 fixes this problem.
If it is the other one would you please confirm, so we can get that on the
branch, and if it's this one is it possible to get it on the branch?

I am running into this problem in my "real" use of the net, not just in testing
so it seems worth getting on the branch.
(Assignee)

Comment 22

16 years ago
bug 143830  fixed this bug.. on the trunk.  After I put that fix in.. I tested
this.. and a few others tested and it was fixed.  I was then told to mark as WFM
as the correct way to resolve this.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.