Outlines do not follow the curved edge of elements with -moz-border-radius set

VERIFIED DUPLICATE of bug 24676

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 24676
20 years ago
19 years ago

People

(Reporter: bugs, Assigned: dcone)

Tracking

({css-moz})

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Try this code:

div#button {
    border            : 2px outset #CCCCDD;
    outline           : 1px solid #000000;
    -moz-border-radius : 6px;
}

<div id="button">
this is a button
</div>

notice that the border of the div is curved, but the outline surrounds the
rectangle of the div, rather than curving around the edge. I believe this is
required for appearance tuning of XP Widgets.

Updated

20 years ago
Assignee: peterl → rods

Comment 1

20 years ago
Rod, I seem to recall you added the outline rendering code, it apparently is
bypassing the rounded corner logic?

Updated

20 years ago
Assignee: rods → dcone

Comment 2

20 years ago
Don, this is your dashed outline stuff, this may be a duplicate.
Assignee

Updated

20 years ago
Status: NEW → ASSIGNED
Assignee

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → REMIND
Assignee

Comment 3

20 years ago
This is basically an undefined feature... outlines do not support the rounded
attribute currently.
Summary: Outlines do not follow the curved edge of elements with -moz-border-radius set → {css-moz} Outlines do not follow the curved edge of elements with -moz-border-radius set

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
Verified REMIND

Comment 5

20 years ago
this is needed for the basic widget look and feel for buttons etc. Thanks in adv
Keywords: css-moz
This is now being asked again in the form of bug 24676.
Summary: {css-moz} Outlines do not follow the curved edge of elements with -moz-border-radius set → Outlines do not follow the curved edge of elements with -moz-border-radius set
I'm reopening this...
Status: VERIFIED → REOPENED
Resolution: REMIND → ---
...so that I can mark it as a duplicate of bug 24676.

dcone: Is that correct?


*** This bug has been marked as a duplicate of 24676 ***
Status: REOPENED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → DUPLICATE

Comment 9

19 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.