Closed Bug 153233 Opened 18 years ago Closed 18 years ago

XPCOM gated with Undefined A-Trap

Categories

(Core :: XPCOM, defect, critical)

PowerPC
Mac System 9.x
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 125411

People

(Reporter: keeptruthfree, Assigned: dougt)

Details

MacsBug white screen with "Undefined A-Trap at {hex location}"

long ago I learned to dismiss this with a "gg" go command
it's like a gate... just say "gg" and it continues...

this is the most regular dependable reproducable bug I have ever encountered
somehow this bug never gets fixed no matter what else changes.

this affects anything that uses XPCOM as a base 
mozilla installer, mozilla browser, and moz-netscape installer and browser.

instance one:
the installer unpacks XPCOM and boom...

instance two:
at both launch and quit time... boom...

instance three:
even at crash time (when I find I can exit to shell)
it needs to pass through the gate to exit



I know the big focus on our platform is now Mac OS X
but for a very long time there will still be Mac OS 8.6-9.1 users
and this bug makes XPCOM a very weak foundation for Mozilla projects

could someone address it... 


I have a NuBus (old-world) Mac (PM8100) with a Sonnet G3 card.
I don't know if it's only with NuBus Macs but the G3 card doesn't affect it.
Often I find software unnecessarily requiring the PCI bus found in newer Macs
will work if the "strict library" call is replaced with a "weak library" call.

I used to panic at this bug and considered it a blocker
then I began to ignore it once I realized I could continue past it with "gg"
but I know other people won't guess this (or don't use MacsBug) and panic.
let me clarify "at launch time":

the splash screen finishes and goes away
then it enters MacsBug with the Undefined A-Trap
just before the browser window opens

type "gg" and it continues as if nothing wrong happened
today's build (2002070810) doesn't have the problem
but I'm not counting it as fixed...

just after I first reported the bug
a build (20020621??) didn't have it either.

the problem returned in the next day's build
and the bug remained until it disappeared in today's build

what's the change in mozilla that makes the bug go away?
will the bug return in tomorrow's build?

could someone address this bug
Lenny, this appears to be a duplicate of bug 125411, which was fixed on July 8, 2002. Try a 
build from after that date and, if you still see the trouble, feel free to reopen that bug.

*** This bug has been marked as a duplicate of 125411 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
vrfy dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.