Add support for running page load tests against Fennec

RESOLVED FIXED in Firefox 68

Status

enhancement
P1
normal
RESOLVED FIXED
6 months ago
3 months ago

People

(Reporter: davehunt, Assigned: alexandrui)

Tracking

Version 3
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

We need to be able to compare Fennec page load results with GeckoView.

Depends on: 1533059
See Also: → 1533064

Hi Alex, once Bug 1536758 lands and is all merged to central, can you please take over this work to get Raptor pageload running on Fennec?

:davehunt Already created a patch (comment 1) that you can start with (you can apply that to your latest repo once Bug 1536758 is merged). Ping me on IRC if you have any questions, thanks!

Assignee: dave.hunt → alexandru.ionescu
Depends on: 1536758
No longer depends on: 1533059
Flags: needinfo?(alexandru.ionescu)

Hi Rob, sure.

Flags: needinfo?(alexandru.ionescu)

Hi Rob, below is a try build. Sorry, I had some issues importing the patch and I applied the changes manually that's why there are 2 phab revisions.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=cf5c23efd7dbb60d268311efe2e59643e1c5d965

All seems to be green.

Flags: needinfo?(rwood)

I've commented in the phab request (no need to NI me in the bug when you've submitted a phab review, thanks!)

:davehunt, I'm assuming for now we want to land this for local use only (i.e. so we can run tp6 on a local device with a specific version of fennec). Do we want these tp6 suites to land in production also? Maybe just on try for now? If so then we'll need taskcluster configs added to your patch Alex.

Flags: needinfo?(rwood) → needinfo?(dave.hunt)

Since FCP ins't available in fennec v64, and that's the version we want to compare - let's just land local support for now (without FCP). If we want to add taskcluster production jobs in the future to run on newer Fennec then we can add FCP at that time.

Flags: needinfo?(dave.hunt)
Depends on: 1541431

(In reply to Robert Wood [:rwood] from comment #6)

I've commented in the phab request (no need to NI me in the bug when you've submitted a phab review, thanks!)

:davehunt, I'm assuming for now we want to land this for local use only (i.e. so we can run tp6 on a local device with a specific version of fennec). Do we want these tp6 suites to land in production also? Maybe just on try for now? If so then we'll need taskcluster configs added to your patch Alex.

It would be good to include try support in this patch.

The try run is failing, but I'm not sure why. Are you able to trigger the speedometer job on try?

Flags: needinfo?(alexandru.ionescu)

I pushed a speedometer job on try, looks like the same results.

Flags: needinfo?(alexandru.ionescu)
Blocks: 1541431
No longer depends on: 1541431
Attachment #9048417 - Attachment is obsolete: true
Pushed by dhunt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/390bf9dcba1a
Add support for running page load tests against Fennec r=rwood
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

If you look at the log [0] you'll see the error "raptor-manifest abort: specified test name doesn't exist". This should really be the error picked up by Treeherder, but I think bug 1522604 is preventing this. The error suggests that the test cannot be found. I would expect that this would be reproducable locally. Can you update mozilla-central to the latest revision and push to try again, requesting these jobs. If it still fails please open a new bug as this one have been resolved.

[0] https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=239025580&repo=try&lineNumber=911

Flags: needinfo?(dave.hunt)
Blocks: 1551194
You need to log in before you can comment on or make changes to this bug.