Support syncing complete BrowsingContextGroups over IPC

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P2
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: Nika, Assigned: Nika)

Tracking

(Blocks 1 bug)

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Fission Milestone:M2, firefox67 fixed)

Details

Attachments

(6 attachments)

This is needed to support adding new content processes to participate in the browsing context group dynamically.

This patch does not cover allowing a content process to leave the BrowsingContextGroup.

Updated

2 months ago
Duplicate of this bug: 1529561
Component: DOM → DOM: Core & HTML
Product: Core → Core

Comment 8

2 months ago
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/84d076d2163d
Part 1: Perform basic validation on CanonicalBrowsingContext, r=farre
https://hg.mozilla.org/integration/autoland/rev/a39da23d450b
Part 2: Use a field list macro header for synced fields, r=farre
https://hg.mozilla.org/integration/autoland/rev/58f77fa35eea
Part 3: Add WillSetX and DidSetX callbacks for BrowsingContext synced fields, r=farre
https://hg.mozilla.org/integration/autoland/rev/9ce1a2365aff
Part 4: Support initializing complete BrowsingContextGroups in a single op with an IPCInitializer struct, r=farre
https://hg.mozilla.org/integration/autoland/rev/856a3d16a4ca
Part 5: Make the BrowsingContext opener edge a weak reference, r=farre
https://hg.mozilla.org/integration/autoland/rev/97c2ee22169c
Part 6: Clean up BrowsingContext references more reliably, r=farre
Depends on: 1539069

Part 1 here broke mouse events for out-of-process iframes. Bug 1539069.

You need to log in before you can comment on or make changes to this bug.