Closed Bug 1532704 Opened 2 years ago Closed 4 months ago

Crash in [@ java.lang.SecurityException: at android.os.Parcel.readException(Parcel.java)]

Categories

(Firefox for Android Graveyard :: General, defect, P2)

Unspecified
Android
defect

Tracking

(firefox-esr68 affected, firefox65 wontfix, firefox66 fix-optional, firefox67 wontfix, firefox68 unaffected)

RESOLVED INCOMPLETE
Tracking Status
firefox-esr68 --- affected
firefox65 --- wontfix
firefox66 --- fix-optional
firefox67 --- wontfix
firefox68 --- unaffected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-da734636-6d8c-4773-9efe-c7a810190305.

Seen while looking at 65 crash stats. This crash has been around before in different forms, including most recently in the 59 cycle as Bug 1431504. It currently sits as the #3 overall top crash in 65.0.1 release.

I performed a six month query of crashes in this signature and it appears that this crash has been rising in frequency since mid December: https://bit.ly/2HdAvsg

The top crashing devices are both Meizu - 16th and 16th Plus. The next highest crashing device is the Samsung Galaxy S8. Some comments:

*crashes if I try to open PDF file in Firefox, then close whole browser, and then open it again
*tried to open a PDF 17kb
*deleted cache

Java stack trace:

java.lang.SecurityException
	at android.os.Parcel.readException(Parcel.java:1967)
	at android.os.Parcel.readException(Parcel.java:1913)
	at android.app.IActivityManager$Stub$Proxy.startActivity(IActivityManager.java:4876)
	at android.app.Instrumentation.execStartActivity(Instrumentation.java:1617)
	at android.app.Activity.startActivityForResult(Activity.java:4564)
	at android.app.Activity.startActivityForResult(Activity.java:4522)
	at android.app.Activity.startActivity(Activity.java:4883)
	at android.app.Activity.startActivity(Activity.java:4851)
	at org.mozilla.gecko.LauncherActivity.dispatchNormalIntent(LauncherActivity.java:119)
	at org.mozilla.gecko.LauncherActivity.onCreate(LauncherActivity.java:75)
	at android.app.Activity.performCreate(Activity.java:7183)
	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1220)
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2910)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:3032)
	at android.app.ActivityThread.-wrap11(Unknown Source:0)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1696)
	at android.os.Handler.dispatchMessage(Handler.java:105)
	at android.os.Looper.loop(Looper.java:164)
	at android.app.ActivityThread.main(ActivityThread.java:6944)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.Zygote$MethodAndArgsCaller.run(Zygote.java:327)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1374)

Stefan, do you think we should be tracking this for 66 uplift?

Flags: needinfo?(sarentz)

Combined total of over 21K crashes on both 65/65.0.1.

Hello Sorina, do you think someone could do some testing around PDFs to see if we can reproduce?

Flags: needinfo?(sorina.florean)

Using the aggregate on the Java stack trace full this is a very sharded crash. The top aggregation is 23 crashes.

  • java.lang.SecurityException: Neither user 10195 nor current process has android.permission.WAKE_LOCK
  • java.lang.SecurityException: Invalid columns in request: notificationclass
  • java.lang.SecurityException: Invalid value for visibility: 2 at android.os.Parcel.readException(Parcel.java:1683)
  • java.lang.SecurityException: UID 10151 does not have permission to content://media/external/file/117 [user 0]

(In reply to Marcia Knous [:marcia - needinfo? me] from comment #3)

Hello Sorina, do you think someone could do some testing around PDFs to see if we can reproduce?

Sure. Stefan, could you please investigate this today? thanks!

Flags: needinfo?(sorina.florean) → needinfo?(stefan.deiac)

Hi, I tried to reproduce this crash on the Release 65.0.1 but without any success.
Firstly I tried the scenarios specified by Marcia on comment 0 and comment 3 and after that, I searched in the signature of this crash more information from the comments and devices to verify multiple situations.
Steps:

  • I watched a stream and paused it, restarted, refreshed the page, stop the net;
  • I opened several pages like nytimes.com, Instagram, kervinjuniorft.blogspot.com;
  • I copied the links and pasted on a different tab.

We don't have Meizu phones here but I tested with other 3 devices from the crash list.

Devices:

  • OnePlus 5T (Android 9);
  • Nexus 6P (Android 8.1.0);
  • Samsung Galaxy S8 (Android 8.0).
Flags: needinfo?(stefan.deiac)

ni to try to parse out the various proto signatures.

Flags: needinfo?(mozillamarcia.knous)

https://bit.ly/2CizvQj is a query that shows the various stack traces. As Kevin notes, the top aggregation doesn't have very many crashes (68). The second one seems to be Samsung specific (directpeninput). So despite the fact we have high volume, I am not sure there is much more we can do here with so many different crashes under one signature (other than maybe add this to the skip list?).

Flags: needinfo?(mozillamarcia.knous)

It seems that java.lang.SecurityException: UID $INTEGER does not have permission to content://$FILE_PATH [user 0 makes for a hard to aggregate crash as there are two parts to the string that are variable.

Hi, I tried to reproduce this crash based on the latest comments from the signature:

  • copying on the clipboard;
  • watch a stream;
  • open some pages;
  • restart the app/device;
  • upload/download files;
  • browsing Play Store).

Devices:

  • Samsung Galaxy S7 Edge (Android 8.0.0);
  • Huawei P20 Lite (Android 8.0).

Unfortunately, I wasn't able to find steps for this crash. I spoke with Petru Lingurar for some help and he will take an eye on this crash.
Laurentiu, can you check also on Samsung S7? We only have S7 Edge here.

Flags: needinfo?(laurentiu.apahidean)

Hello,

I tried to reproduce this crash on a Samsung Galaxy S7 (Android 7.0) performing the scenarios Stefan suggested in Comment 10 but was unable to.

Flags: needinfo?(laurentiu.apahidean)

Let's add this to the skip list so that we might get more useful information. n-i to myself to file a bug for that.

Flags: needinfo?(lhenry)

Filed bug 1541108 for the skiplist.

Flags: needinfo?(lhenry)

Although we had some crashes in 67 nightly, they stopped end of March and we don't have crashes in 67 beta, so wontfix for 67.

There are consistent crashes in 68 cycle in this signature, but without the skip list I am not sure how actionable this crash is. In 68.0b11 this is the #3 overall top crash. Removing the ni for Stefan since it is now out of date.

Flags: needinfo?(sarentz)

Updating tracking flag since this is quite high in both release, beta and nightly.

#5 overall in 68.1.1. 50% correlation to API 27:

(53.32% in signature vs 13.57% overall) android_version = 27 (REL)

Top crashing devices are all https://m.meizu.com/en followed by a group of Samsung devices: S7, J7 and A3 are some of them.

We have completed our launch of our new Firefox on Android. The development of the new versions use GitHub for issue tracking. If the bug report still reproduces in a current version of [Firefox on Android nightly](https://play.google.com/store/apps/details?id=org.mozilla.fenix) an issue can be reported at the [Fenix GitHub project](https://github.com/mozilla-mobile/fenix/). If you want to discuss your report please use [Mozilla's chat](https://wiki.mozilla.org/Matrix#Connect_to_Matrix) server https://chat.mozilla.org and join the [#fenix](https://chat.mozilla.org/#/room/#fenix:mozilla.org) channel.
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → INCOMPLETE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.