Add Facebook Container Icon to be used in the URL bar when in Facebook Container

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P1
normal
RESOLVED FIXED
3 months ago
27 days ago

People

(Reporter: epang, Assigned: groovecoder)

Tracking

Trunk
Firefox 68
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox67 fixed, firefox68 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 months ago
Posted image fbc-icon.svg

To potentially be used with the Facebook container Addon. If possible, the icon does not need to appear in MaC.

(Reporter)

Updated

3 months ago
Summary: Add Facebook Container Icon to MaC → Add Facebook Container Icon to be used in the URL bar when in Facebook Container

Instead of hardcoding an icon here, can we expose a WebExtension API that allows the extension to set the icon? Because we may want to use a different Facebook Container icon in the future.

  • Either MaC would have to hide facebook container or it would have to be able to customise it
  • To enable Facebook container to have the ability to create this icon, then it would need to be exposed as part of the contextualIdentities icon list
  • The about:preferences#containers list will also need to be updated to be able to customise this icon also otherwise the UI will be broken there too

TL;DR without special work to make this a hidden icon, it would be easier just to expose it to all the things and fix MaC, FB container and Firefox too.

This bug specifically will be related to adding the new icon named "fence" to the existing list within firefox.

We then have the rollout issue of enabling this with fb container to solve whilst this rides the trains. For example creating/updating a contextualIdentity with unknown icons is a rejected promise: https://searchfox.org/mozilla-central/rev/3e0f1d95fcf8832413457e3bec802113bdd1f8e8/toolkit/components/extensions/parent/ext-contextualIdentities.js#52 so the fb-container add-on will need to:

  • try creating with the fence
  • fallback to a circle
  • then inject an override through privileged signing to fix the relevant icons

If this patch is small enough we should try and get this uplifted as far as possible to simplify the process fb container has to do here.

Depends on: 1479433

Comment 3

2 months ago

Lets start with just adding the fence icon as a container icon option in the platform in this bug. And file a followup to give extensions more capabilities if possible.

See Also: → 1533542
(Assignee)

Updated

a month ago
Assignee: shivangikakkar15 → lcrouch
(Assignee)

Comment 4

a month ago

Adds a gray color and fence icon for Containers. This is originally from
Facebook Container: https://addons.mozilla.org/firefox/addon/facebook-container/

User Research showed a strong affinity for the fence icon as an indicator of
the kind of "boundary" protection that Containers provide.
https://docs.google.com/spreadsheets/d/1bnqjcWTV893RESMPJzAXOrDN0juN_Z0-EE93Mvn3Z5g/edit#gid=0

Status: NEW → ASSIGNED
Priority: -- → P1
(Assignee)

Updated

a month ago
Keywords: checkin-needed

Comment 5

a month ago

Pushed by jkingston@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0bbaddcea393
contextualIdentity: add gray color and fence icon ; r=jkt,flod

Keywords: checkin-needed

Comment 6

a month ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
(Assignee)

Comment 7

a month ago

Thanks :apavel. Do you know how I can request an uplift to Beta? We would like to have this available in Release for Facebook Container 2.0 launch (before June).

Flags: needinfo?(apavel)

On the attachment you have, click on Details and below you have the approval selectors. Set the "?" for the approval you want and fill in the details, then submit.

Flags: needinfo?(apavel)
(Assignee)

Comment 9

a month ago

Comment on attachment 9057369 [details]
contextualIdentity: add gray color and fence icon (Bug 1532746); r=jkt

Beta/Release Uplift Approval Request

  • User impact if declined: Facebook Container 2.0 users will continue to have the janky briefcase icon.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1479433
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky because we've verified in Nightly, and the number of users who use Containers is low.
  • String changes made/needed: No visible UI strings; but includes accessibility labels for the new fence icon and "Match toolbar" color options for containers
Attachment #9057369 - Flags: approval-mozilla-beta?

Comment on attachment 9057369 [details]
contextualIdentity: add gray color and fence icon (Bug 1532746); r=jkt

Low risk, uplift accepted for 67 beta 13, thanks.

Attachment #9057369 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Marking as qe-verify- based on its automated coverage.

Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.